summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/pxp/pxp-1.1.6.ebuild')
-rw-r--r--dev-ml/pxp/pxp-1.1.6.ebuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/dev-ml/pxp/pxp-1.1.6.ebuild b/dev-ml/pxp/pxp-1.1.6.ebuild
index 153e2292e00e..8d8f139976aa 100644
--- a/dev-ml/pxp/pxp-1.1.6.ebuild
+++ b/dev-ml/pxp/pxp-1.1.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/pxp-1.1.6.ebuild,v 1.1 2004/08/18 20:27:01 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/pxp-1.1.6.ebuild,v 1.2 2004/08/25 13:29:32 mattam Exp $
+
+inherit findlib
DESCRIPTION="validating XML parser library for O'Caml"
HOMEPAGE="http://www.ocaml-programming.de/packages/documentation/pxp/index_dev.html"
@@ -9,11 +11,11 @@ SRC_URI="http://www.ocaml-programming.de/packages/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86"
-IUSE=""
+IUSE="doc"
-DEPEND=">=dev-ml/pcre-ocaml-4.31
- >=dev-ml/ocamlnet-0.94
- >=dev-ml/findlib-0.8"
+DEPEND="dev-lang/ocaml
+>=dev-ml/pcre-ocaml-4.31
+>=dev-ml/ocamlnet-0.94"
src_compile() {
#the included configure does not support many standard switches and is quite picky
@@ -22,7 +24,15 @@ src_compile() {
}
src_install() {
- local destdir=`ocamlfind printconf destdir`
- dodir ${destdir}
- make OCAMLFIND_DESTDIR=${D}${destdir} install || die
+ findlib_src_install
+
+ cd doc
+ dodoc ABOUT-FINDLIB DEV EXTENSIONS README RELEASE-NOTES SPEC design.txt
+
+ if use doc; then
+ dodoc manual/ps/pxp.ps
+ dohtml manual/html/*
+ insinto /usr/share/doc/${PF}/html/pic
+ doins manual/html/pic/*
+ fi
}