summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/File-Slurp-Tiny/ChangeLog8
-rw-r--r--dev-perl/File-Slurp-Tiny/File-Slurp-Tiny-0.4.0.ebuild (renamed from dev-perl/File-Slurp-Tiny/File-Slurp-Tiny-0.003.ebuild)20
2 files changed, 23 insertions, 5 deletions
diff --git a/dev-perl/File-Slurp-Tiny/ChangeLog b/dev-perl/File-Slurp-Tiny/ChangeLog
index ae6b9f3c3a58..a6e972029dc7 100644
--- a/dev-perl/File-Slurp-Tiny/ChangeLog
+++ b/dev-perl/File-Slurp-Tiny/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/File-Slurp-Tiny
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/File-Slurp-Tiny/ChangeLog,v 1.1 2015/03/13 17:27:26 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/File-Slurp-Tiny/ChangeLog,v 1.2 2015/07/21 22:55:07 dilfridge Exp $
+
+*File-Slurp-Tiny-0.4.0 (21 Jul 2015)
+
+ 21 Jul 2015; Andreas K. Huettel <dilfridge@gentoo.org>
+ +File-Slurp-Tiny-0.4.0.ebuild, -File-Slurp-Tiny-0.003.ebuild:
+ Version bump, add dependencies, fix versioning
*File-Slurp-Tiny-0.003 (13 Mar 2015)
diff --git a/dev-perl/File-Slurp-Tiny/File-Slurp-Tiny-0.003.ebuild b/dev-perl/File-Slurp-Tiny/File-Slurp-Tiny-0.4.0.ebuild
index 3a6f25a0f6c7..84447748f62b 100644
--- a/dev-perl/File-Slurp-Tiny/File-Slurp-Tiny-0.003.ebuild
+++ b/dev-perl/File-Slurp-Tiny/File-Slurp-Tiny-0.4.0.ebuild
@@ -1,17 +1,29 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/File-Slurp-Tiny/File-Slurp-Tiny-0.003.ebuild,v 1.1 2015/03/13 17:27:26 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/File-Slurp-Tiny/File-Slurp-Tiny-0.4.0.ebuild,v 1.1 2015/07/21 22:55:07 dilfridge Exp $
EAPI=5
MODULE_AUTHOR=LEONT
-MODULE_VERSION=0.003
+MODULE_VERSION=0.004
inherit perl-module
DESCRIPTION="A simple, sane and efficient file slurper"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
+IUSE="test"
-SRC_TEST="do"
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Exporter-5.570.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Temp
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST="do parallel"