summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php5/znf/znf-0.7.6.ebuild')
-rw-r--r--dev-php5/znf/znf-0.7.6.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-php5/znf/znf-0.7.6.ebuild b/dev-php5/znf/znf-0.7.6.ebuild
index 19750d59e8bd..571005cce80a 100644
--- a/dev-php5/znf/znf-0.7.6.ebuild
+++ b/dev-php5/znf/znf-0.7.6.ebuild
@@ -1,28 +1,29 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/znf/znf-0.7.6.ebuild,v 1.3 2006/04/19 01:37:53 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/znf/znf-0.7.6.ebuild,v 1.4 2007/03/18 03:21:08 chtekk Exp $
inherit php-pear-lib-r1
-KEYWORDS="~sparc ~x86"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+MY_P="ZNF-${PV}"
+
DESCRIPTION="PHP5 MVC framework for enterprise web applications."
HOMEPAGE="http://znf.zeronotice.com/"
+SRC_URI="mirror://sourceforge/znf/${MY_P}.tgz"
LICENSE="LGPL-2.1"
SLOT="0"
IUSE="pear-db smarty"
-MY_P="ZNF-${PV}"
-SRC_URI="mirror://sourceforge/znf/${MY_P}.tgz"
-S="${WORKDIR}/${MY_P}"
-
+DEPEND=""
RDEPEND="pear-db? ( >=dev-php/PEAR-DB-1.7.6-r1 )
smarty? ( >=dev-php/smarty-2.6.10-r1 )"
+S="${WORKDIR}/${MY_P}"
+
need_php_by_category
pkg_setup() {
has_php
-
- # we need XML/XSL support in PHP5 for this
require_php_with_use xml xsl
}