summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libwnck-python/libwnck-python-2.22.0.ebuild')
-rw-r--r--dev-python/libwnck-python/libwnck-python-2.22.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/libwnck-python/libwnck-python-2.22.0.ebuild b/dev-python/libwnck-python/libwnck-python-2.22.0.ebuild
new file mode 100644
index 000000000000..475238ad361a
--- /dev/null
+++ b/dev-python/libwnck-python/libwnck-python-2.22.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libwnck-python/libwnck-python-2.22.0.ebuild,v 1.1 2008/09/14 17:01:16 ford_prefect Exp $
+
+G_PY_PN="gnome-python-desktop"
+G_PY_BINDINGS="wnck"
+
+inherit gnome-python-common
+
+DESCRIPTION="Python bindings for the libwnck library"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${G_PY_PN}-${PV}-split.patch.gz"
+
+RDEPEND=">=x11-libs/libwnck-2.19.3
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}"
+
+EXAMPLES="examples/wnck_example.py"
+
+src_unpack() {
+ gnome-python-common_src_unpack
+ cd "${S}"
+ epatch "${WORKDIR}/${G_PY_PN}-${PV}-split.patch"
+ eautoreconf
+}