summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/logbook')
-rw-r--r--dev-python/logbook/ChangeLog6
-rw-r--r--dev-python/logbook/logbook-0.10.0.ebuild6
-rw-r--r--dev-python/logbook/logbook-0.8.1.ebuild44
-rw-r--r--dev-python/logbook/logbook-0.9.0.ebuild44
-rw-r--r--dev-python/logbook/logbook-0.9.1.ebuild6
5 files changed, 12 insertions, 94 deletions
diff --git a/dev-python/logbook/ChangeLog b/dev-python/logbook/ChangeLog
index 1620cc178178..9d7c84b04f62 100644
--- a/dev-python/logbook/ChangeLog
+++ b/dev-python/logbook/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/logbook
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.25 2015/07/19 01:51:25 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.26 2015/07/19 04:21:53 idella4 Exp $
+
+ 19 Jul 2015; Ian Delaney <idella4@gentoo.org> -logbook-0.8.1.ebuild,
+ -logbook-0.9.0.ebuild, logbook-0.10.0.ebuild, logbook-0.9.1.ebuild:
+ add missing dep, typos, rm old
*logbook-0.10.0 (19 Jul 2015)
diff --git a/dev-python/logbook/logbook-0.10.0.ebuild b/dev-python/logbook/logbook-0.10.0.ebuild
index 924ba9e823ce..f3c163b8906c 100644
--- a/dev-python/logbook/logbook-0.10.0.ebuild
+++ b/dev-python/logbook/logbook-0.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.10.0.ebuild,v 1.1 2015/07/19 01:51:25 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.10.0.ebuild,v 1.2 2015/07/19 04:21:53 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -20,7 +20,9 @@ DISTUTILS_IN_SOURCE_BUILD=1
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
-REDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]"
PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )
diff --git a/dev-python/logbook/logbook-0.8.1.ebuild b/dev-python/logbook/logbook-0.8.1.ebuild
deleted file mode 100644
index 7708dcf4a12c..000000000000
--- a/dev-python/logbook/logbook-0.8.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.8.1.ebuild,v 1.1 2014/12/14 10:52:16 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A logging replacement for Python"
-HOMEPAGE="http://packages.python.org/Logbook/ http://pypi.python.org/pypi/Logbook"
-SRC_URI="https://github.com/mitsuhiko/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
-REDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )
-
-python_prepare_all() {
- # Delete test file requiring local conncetion to redis server
- rm tests/test_queues.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/logbook/logbook-0.9.0.ebuild b/dev-python/logbook/logbook-0.9.0.ebuild
deleted file mode 100644
index f307fdcf4ed4..000000000000
--- a/dev-python/logbook/logbook-0.9.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.9.0.ebuild,v 1.1 2015/03/17 07:16:02 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A logging replacement for Python"
-HOMEPAGE="http://packages.python.org/Logbook/ http://pypi.python.org/pypi/Logbook"
-SRC_URI="https://github.com/mitsuhiko/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
-REDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )
-
-python_prepare_all() {
- # Delete test file requiring local conncetion to redis server
- rm tests/test_queues.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/logbook/logbook-0.9.1.ebuild b/dev-python/logbook/logbook-0.9.1.ebuild
index 19db75d4f33b..179457e13613 100644
--- a/dev-python/logbook/logbook-0.9.1.ebuild
+++ b/dev-python/logbook/logbook-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.9.1.ebuild,v 1.1 2015/06/15 21:50:42 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.9.1.ebuild,v 1.2 2015/07/19 04:21:53 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -20,12 +20,12 @@ DISTUTILS_IN_SOURCE_BUILD=1
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
-REDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]"
PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )
python_prepare_all() {
- # Delete test file requiring local conncetion to redis server
+ # Delete test file requiring local connection to redis server
rm tests/test_queues.py || die
distutils-r1_python_prepare_all
}