summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycrypto/pycrypto-2.0.1.ebuild')
-rw-r--r--dev-python/pycrypto/pycrypto-2.0.1.ebuild27
1 files changed, 20 insertions, 7 deletions
diff --git a/dev-python/pycrypto/pycrypto-2.0.1.ebuild b/dev-python/pycrypto/pycrypto-2.0.1.ebuild
index 85676f1cba3a..35144bf83935 100644
--- a/dev-python/pycrypto/pycrypto-2.0.1.ebuild
+++ b/dev-python/pycrypto/pycrypto-2.0.1.ebuild
@@ -1,15 +1,28 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycrypto/pycrypto-2.0.1.ebuild,v 1.4 2005/08/27 20:04:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycrypto/pycrypto-2.0.1.ebuild,v 1.5 2006/01/06 23:08:29 vapier Exp $
-inherit distutils
+inherit eutils distutils
DESCRIPTION="Python Cryptography Toolkit"
HOMEPAGE="http://www.amk.ca/python/code/crypto.html"
SRC_URI="http://www.amk.ca/files/python/crypto/${P}.tar.gz"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+
LICENSE="freedist"
-DEPEND="virtual/python"
SLOT="0"
-IUSE=""
-DOCS="ACKS ChangeLog LICENSE MANIFEST PKG-INFO README TODO Doc/pycrypt.tex"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sh ~sparc ~x86"
+IUSE="bindist"
+
+DEPEND="virtual/python"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use bindist && epatch "${FILESDIR}"/${P}-bindist.patch
+}
+
+src_test() {
+ python ./test.py || die "test failed"
+}
+
+DOCS="ACKS ChangeLog PKG-INFO README TODO Doc/pycrypt.tex"