summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygtk/files/pygtk-2.12.1-fix-codegen-location.patch')
-rw-r--r--dev-python/pygtk/files/pygtk-2.12.1-fix-codegen-location.patch54
1 files changed, 27 insertions, 27 deletions
diff --git a/dev-python/pygtk/files/pygtk-2.12.1-fix-codegen-location.patch b/dev-python/pygtk/files/pygtk-2.12.1-fix-codegen-location.patch
index 4d65927f5e01..9283a74f44a1 100644
--- a/dev-python/pygtk/files/pygtk-2.12.1-fix-codegen-location.patch
+++ b/dev-python/pygtk/files/pygtk-2.12.1-fix-codegen-location.patch
@@ -1,22 +1,23 @@
-Index: pygtk-2.0.pc.in
-===================================================================
---- pygtk-2.0.pc.in (revision 2949)
-+++ pygtk-2.0.pc.in (working copy)
-@@ -12,7 +12,7 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN pygtk-2.12.1.orig/codegen/Makefile.am pygtk-2.12.1/codegen/Makefile.am
+--- pygtk-2.12.1.orig/codegen/Makefile.am 2007-11-01 12:20:22.000000000 -0400
++++ pygtk-2.12.1/codegen/Makefile.am 2008-05-28 22:21:04.000000000 -0400
+@@ -2,7 +2,7 @@ PLATFORM_VERSION = 2.0
- # same here. Useful when calling the code generator in addon packages.
- defsdir=${datadir}/pygtk/2.0/defs
--codegendir=${datadir}/pygtk/2.0/codegen
-+codegendir=${pyexecdir}/gtk-2.0/codegen
+ bin_SCRIPTS = pygtk-codegen-$(PLATFORM_VERSION)
+
+-codegendir = $(pkgdatadir)/$(PLATFORM_VERSION)/codegen
++codegendir = $(pyexecdir)/gtk-2.0/codegen
+
+ codegen_PYTHON = \
+ __init__.py \
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN pygtk-2.12.1.orig/codegen/pygtk-codegen-2.0.in pygtk-2.12.1/codegen/pygtk-codegen-2.0.in
+--- pygtk-2.12.1.orig/codegen/pygtk-codegen-2.0.in 2007-11-01 12:20:22.000000000 -0400
++++ pygtk-2.12.1/codegen/pygtk-codegen-2.0.in 2008-05-28 22:24:38.000000000 -0400
+@@ -1,9 +1,10 @@
+ #!/bin/sh
- Name: PyGTK
- Description: Python bindings for GTK+ and related libraries
-Index: codegen/pygtk-codegen-2.0.in
-===================================================================
---- codegen/pygtk-codegen-2.0.in (revision 2949)
-+++ codegen/pygtk-codegen-2.0.in (working copy)
-@@ -3,7 +3,7 @@
prefix=@prefix@
++exec_prefix=@exec_prefix@
datarootdir=@datarootdir@
datadir=@datadir@
-codegendir=${datadir}/pygtk/2.0/codegen
@@ -24,16 +25,15 @@ Index: codegen/pygtk-codegen-2.0.in
PYTHONPATH=$codegendir
export PYTHONPATH
-Index: codegen/Makefile.am
-===================================================================
---- codegen/Makefile.am (revision 2949)
-+++ codegen/Makefile.am (working copy)
-@@ -2,7 +2,7 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN pygtk-2.12.1.orig/pygtk-2.0.pc.in pygtk-2.12.1/pygtk-2.0.pc.in
+--- pygtk-2.12.1.orig/pygtk-2.0.pc.in 2007-11-01 12:20:22.000000000 -0400
++++ pygtk-2.12.1/pygtk-2.0.pc.in 2008-05-28 22:21:04.000000000 -0400
+@@ -12,7 +12,7 @@ pygtkincludedir=${includedir}/pygtk-2.0
- bin_SCRIPTS = pygtk-codegen-$(PLATFORM_VERSION)
-
--codegendir = $(pkgdatadir)/$(PLATFORM_VERSION)/codegen
-+codegendir = $(pyexecdir)/gtk-2.0/codegen
+ # same here. Useful when calling the code generator in addon packages.
+ defsdir=${datadir}/pygtk/2.0/defs
+-codegendir=${datadir}/pygtk/2.0/codegen
++codegendir=${pyexecdir}/gtk-2.0/codegen
- codegen_PYTHON = \
- __init__.py \
+ Name: PyGTK
+ Description: Python bindings for GTK+ and related libraries