summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyopencl/pyopencl-2012.1.ebuild')
-rw-r--r--dev-python/pyopencl/pyopencl-2012.1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/pyopencl/pyopencl-2012.1.ebuild b/dev-python/pyopencl/pyopencl-2012.1.ebuild
deleted file mode 100644
index f83fe3bd65fc..000000000000
--- a/dev-python/pyopencl/pyopencl-2012.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2012.1.ebuild,v 1.1 2012/06/28 07:20:28 patrick Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples opengl"
-
-RDEPEND=">=dev-libs/boost-1.48[python]
- dev-python/decorator
- dev-python/numpy
- dev-python/mako
- dev-python/pytools
- >=virtual/opencl-0-r1"
-DEPEND="${RDEPEND}"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-
-src_configure()
-{
- configuration() {
- local myconf=()
-
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "$(PYTHON)" configure.py \
- --boost-compiler=gcc \
- --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
- --no-use-shipped-boost \
- "${myconf[@]}"
- }
- python_execute_function -s configuration
-}
-
-src_install()
-{
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-pkg_postinst()
-{
- distutils_pkg_postinst
- if use examples; then
- elog "Some of the examples provided by this package require dev-python/matplotlib."
- fi
-}