summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/werkzeug/werkzeug-0.3.1.ebuild')
-rw-r--r--dev-python/werkzeug/werkzeug-0.3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/werkzeug/werkzeug-0.3.1.ebuild b/dev-python/werkzeug/werkzeug-0.3.1.ebuild
new file mode 100644
index 000000000000..0e15629fc3bc
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.3.1.ebuild,v 1.1 2008/07/20 13:31:12 hoffie Exp $
+
+NEED_PYTHON="2.4"
+
+inherit distutils
+
+MY_P="Werkzeug-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/"
+SRC_URI="http://pypi.python.org/packages/source/W/Werkzeug/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND=">=dev-python/setuptools-0.6_rc5
+ test? ( dev-python/py
+ dev-python/lxml
+ dev-python/simplejson )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES"
+
+src_test() {
+ distutils_python_version
+ # path gets set correctly in conftest.py
+ cd tests
+ py.test || die "tests failed"
+}