summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/capistrano/capistrano-2.5.9.ebuild')
-rw-r--r--dev-ruby/capistrano/capistrano-2.5.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/capistrano-2.5.9.ebuild b/dev-ruby/capistrano/capistrano-2.5.9.ebuild
new file mode 100644
index 000000000000..dd901ad4a5db
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.5.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-2.5.9.ebuild,v 1.1 2009/10/23 15:16:22 graaff Exp $
+
+inherit gems
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capify.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+USE_RUBY="ruby18"
+
+DEPEND=">=dev-lang/ruby-1.8.2
+ >=dev-ruby/rubygems-1.3.0
+ >=dev-ruby/net-ssh-2.0.10
+ >=dev-ruby/net-sftp-2.0.2
+ >=dev-ruby/net-scp-1.0.2
+ >=dev-ruby/net-ssh-gateway-1.0.0
+ >=dev-ruby/highline-1.2.7"
+RDEPEND="${DEPEND}"
+PDEPEND="dev-ruby/capistrano-launcher"
+
+src_install() {
+ gems_src_install
+
+ # Deleted cap, as it will be provided by capistrano-launcher
+ rm "${D}/usr/bin/cap"
+ rm "${D}/${GEMSDIR}/bin/cap"
+}