summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/narray/narray-0.5.9.ebuild')
-rw-r--r--dev-ruby/narray/narray-0.5.9.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/narray/narray-0.5.9.ebuild b/dev-ruby/narray/narray-0.5.9.ebuild
new file mode 100644
index 000000000000..7cd6073ae508
--- /dev/null
+++ b/dev-ruby/narray/narray-0.5.9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.5.9.ebuild,v 1.1 2006/08/28 15:22:56 pclouds Exp $
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="http://rubyforge.org/frs/download.php/12235/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/ruby"
+
+src_compile() {
+ ruby extconf.rb || die
+ emake || die
+}
+
+src_install() {
+ make exec_prefix=/usr DESTDIR=${D} install || die
+ dodoc ChangeLog README.* SPEC.*
+}