summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/ChangeLog9
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild31
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/ruby-progressbar/ChangeLog b/dev-ruby/ruby-progressbar/ChangeLog
index 6ae3b518e7cd..da919aaeb6fb 100644
--- a/dev-ruby/ruby-progressbar/ChangeLog
+++ b/dev-ruby/ruby-progressbar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/ruby-progressbar
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.23 2010/01/14 01:09:18 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.24 2010/01/18 02:14:21 flameeyes Exp $
+
+*ruby-progressbar-0.0.9 (18 Jan 2010)
+
+ 18 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +ruby-progressbar-0.0.9.ebuild:
+ Add an updated ruby-progressbar (even though the version results older),
+ and port to fakegem.
14 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-progressbar-0.9.ebuild:
Marking ruby-progressbar-0.9 ppc64 for bug 298236
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild
new file mode 100644
index 000000000000..877b22e253be
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild,v 1.1 2010/01/18 02:14:21 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="http://github.com/nex3/ruby-progressbar"
+
+LICENSE="|| ( Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="test"
+
+each_ruby_test() {
+ # tests need to be run from within the lib dir but they require
+ # lib/progressbar.rb, so we do this silly stuff, but it works at
+ # least
+ cd lib
+ ${RUBY} -I.. ../test.rb || die "test failed"
+}