summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/method_source/ChangeLog9
-rw-r--r--dev-ruby/method_source/method_source-0.8.2.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-ruby/method_source/ChangeLog b/dev-ruby/method_source/ChangeLog
index d8c6776b41b2..105568a95c48 100644
--- a/dev-ruby/method_source/ChangeLog
+++ b/dev-ruby/method_source/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/method_source
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/ChangeLog,v 1.16 2012/12/24 08:03:16 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/ChangeLog,v 1.17 2013/07/28 20:36:32 mrueg Exp $
+
+*method_source-0.8.2 (28 Jul 2013)
+
+ 28 Jul 2013; Manuel Rüger <mrueg@gentoo.org> +method_source-0.8.2.ebuild:
+ Version bump
*method_source-0.8.1 (24 Dec 2012)
diff --git a/dev-ruby/method_source/method_source-0.8.2.ebuild b/dev-ruby/method_source/method_source-0.8.2.ebuild
new file mode 100644
index 000000000000..d950f2b06834
--- /dev/null
+++ b/dev-ruby/method_source/method_source-0.8.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/method_source-0.8.2.ebuild,v 1.1 2013/07/28 20:36:32 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the source code for a method."
+HOMEPAGE="http://github.com/banister/method_source"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 )"
+
+each_ruby_test() {
+ ${RUBY} -I. -S bacon -k test/test.rb || die "Tests failed."
+}