summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile/files')
-rw-r--r--dev-scheme/guile/files/50guile-gentoo.el3
-rw-r--r--dev-scheme/guile/files/fix-reader-cr.diff11
-rw-r--r--dev-scheme/guile/files/guile-1.4-inet_aton.patch16
-rw-r--r--dev-scheme/guile/files/guile-1.6.7-gcc4.patch11
-rw-r--r--dev-scheme/guile/files/guile-1.6.7-posix.patch16
-rw-r--r--dev-scheme/guile/files/guile-1.6.7-scmsigs.patch11
-rw-r--r--dev-scheme/guile/files/guile-1.8-rational.patch135
-rw-r--r--dev-scheme/guile/files/guile-1.8.1-autotools_fixes.patch43
-rw-r--r--dev-scheme/guile/files/guile-1.8.1-clog-cexp.patch43
-rw-r--r--dev-scheme/guile/files/guile-1.8.1-defaultincludes.patch12
-rw-r--r--dev-scheme/guile/files/guile-amd64.patch13
11 files changed, 0 insertions, 314 deletions
diff --git a/dev-scheme/guile/files/50guile-gentoo.el b/dev-scheme/guile/files/50guile-gentoo.el
index d7098b12e412..431f7e90ae73 100644
--- a/dev-scheme/guile/files/50guile-gentoo.el
+++ b/dev-scheme/guile/files/50guile-gentoo.el
@@ -1,4 +1 @@
-
-;;; guile site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
diff --git a/dev-scheme/guile/files/fix-reader-cr.diff b/dev-scheme/guile/files/fix-reader-cr.diff
deleted file mode 100644
index 09e9ecae6725..000000000000
--- a/dev-scheme/guile/files/fix-reader-cr.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- orig/libguile/read.c
-+++ mod/libguile/read.c
-@@ -150,7 +150,7 @@ static SCM *scm_read_hash_procedures;
- /* `isblank' is only in C99. */
- #define CHAR_IS_BLANK_(_chr) \
- (((_chr) == ' ') || ((_chr) == '\t') || ((_chr) == '\n') \
-- || ((_chr) == '\f'))
-+ || ((_chr) == '\f') || ((_chr) == '\r'))
-
- #ifdef MSDOS
- # define CHAR_IS_BLANK(_chr) \
diff --git a/dev-scheme/guile/files/guile-1.4-inet_aton.patch b/dev-scheme/guile/files/guile-1.4-inet_aton.patch
deleted file mode 100644
index 9294e1a895af..000000000000
--- a/dev-scheme/guile/files/guile-1.4-inet_aton.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- guile-1.4-r3/work/guile-1.4/libguile/net_db.c 2000-06-14 01:26:05.000000000 +0100
-+++ guile-1.4.1/work/guile-1.4.1/libguile/net_db.c 2002-05-04 03:16:13.000000000 +0100
-@@ -82,9 +80,12 @@
- int close ();
- #endif /* STDC_HEADERS */
-
-+#ifndef HAVE_INET_ATON
-+/* for our definition in inet_aton.c, not usually needed. */
- extern int inet_aton ();
-+#endif
-
--SCM_DEFINE (scm_inet_aton, "inet-aton", 1, 0, 0,
-+SCM_DEFINE (scm_inet_aton, "inet-aton", 1, 0, 0,
- (SCM address),
- "Converts a string containing an Internet host address in the traditional\n"
- "dotted decimal notation into an integer.\n\n"
diff --git a/dev-scheme/guile/files/guile-1.6.7-gcc4.patch b/dev-scheme/guile/files/guile-1.6.7-gcc4.patch
deleted file mode 100644
index 6d2f18d5b156..000000000000
--- a/dev-scheme/guile/files/guile-1.6.7-gcc4.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- guile-1.6.7/libguile/guile.c 2002-12-07 22:41:32.000000000 +0000
-+++ guile-1.6.7.az/libguile/guile.c 2005-04-24 15:43:21.000000000 +0000
-@@ -88,7 +88,7 @@
- {
- #ifdef DYNAMIC_LINKING
- /* libtool automagically inserts this variable into your executable... */
-- extern const scm_lt_dlsymlist lt_preloaded_symbols[];
-+ extern const scm_lt_dlsymlist *lt_preloaded_symbols;
- scm_lt_dlpreload_default (lt_preloaded_symbols);
- #endif
- scm_boot_guile (argc, argv, inner_main, 0);
diff --git a/dev-scheme/guile/files/guile-1.6.7-posix.patch b/dev-scheme/guile/files/guile-1.6.7-posix.patch
deleted file mode 100644
index a4cd2bcaef51..000000000000
--- a/dev-scheme/guile/files/guile-1.6.7-posix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- libguile/posix.c.sav Tue Jan 25 19:01:44 2005
-+++ libguile/posix.c Tue Jan 25 19:01:55 2005
-@@ -1257,6 +1257,13 @@
- SCM_MEMORY_ERROR;
- strncpy (ptr, SCM_STRING_CHARS (str), SCM_STRING_LENGTH (str));
- ptr[SCM_STRING_LENGTH (str)] = 0;
-+#if defined(macosx)
-+ if (!strchr(ptr, '=')) {
-+ unsetenv(ptr);
-+ rv = 0;
-+ }
-+ else
-+#endif
- rv = putenv (ptr);
- if (rv < 0)
- SCM_SYSERROR;
diff --git a/dev-scheme/guile/files/guile-1.6.7-scmsigs.patch b/dev-scheme/guile/files/guile-1.6.7-scmsigs.patch
deleted file mode 100644
index 65b5b52c3dc7..000000000000
--- a/dev-scheme/guile/files/guile-1.6.7-scmsigs.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- libguile/scmsigs.c.sav Tue Feb 11 22:07:54 2003
-+++ libguile/scmsigs.c Tue Feb 11 22:08:18 2003
-@@ -66,7 +66,7 @@
- /* The thread system has its own sleep and usleep functions. */
- #ifndef USE_THREADS
-
--#if defined(MISSING_SLEEP_DECL)
-+#if defined(MISSING_SLEEP_DECL) && ! defined(macosx)
- int sleep ();
- #endif
-
diff --git a/dev-scheme/guile/files/guile-1.8-rational.patch b/dev-scheme/guile/files/guile-1.8-rational.patch
deleted file mode 100644
index 0f9159358783..000000000000
--- a/dev-scheme/guile/files/guile-1.8-rational.patch
+++ /dev/null
@@ -1,135 +0,0 @@
-2006-12-23 Han-Wen Nienhuys <hanwen@lilypond.org>
-
- * numbers.c (scm_i_fraction_reduce): move logic into
- scm_i_make_ratio(), so fractions are only read.
- scm_i_fraction_reduce() modifies a fraction when reading it. A
- race condition might lead to fractions being corrupted by reading
- them concurrently.
-
- Also, the REDUCED bit alters the SCM_CELL_TYPE(), making
- comparisons between reduced and unreduced fractions go wrong.
-
- * numbers.h: remove SCM_FRACTION_SET_NUMERATOR,
- SCM_FRACTION_SET_DENOMINATOR, SCM_FRACTION_REDUCED_BIT,
- SCM_FRACTION_REDUCED_SET, SCM_FRACTION_REDUCED_CLEAR,
- SCM_FRACTION_REDUCED.
-
-Index: libguile/numbers.c
-===================================================================
-RCS file: /cvsroot/guile/guile/guile-core/libguile/numbers.c,v
-retrieving revision 1.285
-diff -p -u -u -r1.285 numbers.c
---- libguile/numbers.c 9 Oct 2006 23:17:30 -0000 1.285
-+++ libguile/numbers.c 23 Dec 2006 20:31:20 -0000
-@@ -452,28 +452,21 @@ scm_i_make_ratio (SCM numerator, SCM den
-
- /* No, it's a proper fraction.
- */
-- return scm_double_cell (scm_tc16_fraction,
-- SCM_UNPACK (numerator),
-- SCM_UNPACK (denominator), 0);
-+ {
-+ SCM divisor = scm_gcd (numerator, denominator);
-+ if (!(scm_is_eq (divisor, SCM_I_MAKINUM(1))))
-+ {
-+ numerator = scm_divide (numerator, divisor);
-+ denominator = scm_divide (denominator, divisor);
-+ }
-+
-+ return scm_double_cell (scm_tc16_fraction,
-+ SCM_UNPACK (numerator),
-+ SCM_UNPACK (denominator), 0);
-+ }
- }
- #undef FUNC_NAME
-
--static void scm_i_fraction_reduce (SCM z)
--{
-- if (!(SCM_FRACTION_REDUCED (z)))
-- {
-- SCM divisor;
-- divisor = scm_gcd (SCM_FRACTION_NUMERATOR (z), SCM_FRACTION_DENOMINATOR (z));
-- if (!(scm_is_eq (divisor, SCM_I_MAKINUM(1))))
-- {
-- /* is this safe? */
-- SCM_FRACTION_SET_NUMERATOR (z, scm_divide (SCM_FRACTION_NUMERATOR (z), divisor));
-- SCM_FRACTION_SET_DENOMINATOR (z, scm_divide (SCM_FRACTION_DENOMINATOR (z), divisor));
-- }
-- SCM_FRACTION_REDUCED_SET (z);
-- }
--}
--
- double
- scm_i_fraction2double (SCM z)
- {
-@@ -2387,7 +2380,6 @@ SCM_DEFINE (scm_number_to_string, "numbe
- }
- else if (SCM_FRACTIONP (n))
- {
-- scm_i_fraction_reduce (n);
- return scm_string_append (scm_list_3 (scm_number_to_string (SCM_FRACTION_NUMERATOR (n), radix),
- scm_from_locale_string ("/"),
- scm_number_to_string (SCM_FRACTION_DENOMINATOR (n), radix)));
-@@ -2441,7 +2433,6 @@ int
- scm_i_print_fraction (SCM sexp, SCM port, scm_print_state *pstate SCM_UNUSED)
- {
- SCM str;
-- scm_i_fraction_reduce (sexp);
- str = scm_number_to_string (sexp, SCM_UNDEFINED);
- scm_lfwrite (scm_i_string_chars (str), scm_i_string_length (str), port);
- scm_remember_upto_here_1 (str);
-@@ -3109,8 +3100,6 @@ scm_complex_equalp (SCM x, SCM y)
- SCM
- scm_i_fraction_equalp (SCM x, SCM y)
- {
-- scm_i_fraction_reduce (x);
-- scm_i_fraction_reduce (y);
- if (scm_is_false (scm_equal_p (SCM_FRACTION_NUMERATOR (x),
- SCM_FRACTION_NUMERATOR (y)))
- || scm_is_false (scm_equal_p (SCM_FRACTION_DENOMINATOR (x),
-@@ -5424,10 +5413,7 @@ scm_numerator (SCM z)
- else if (SCM_BIGP (z))
- return z;
- else if (SCM_FRACTIONP (z))
-- {
-- scm_i_fraction_reduce (z);
-- return SCM_FRACTION_NUMERATOR (z);
-- }
-+ return SCM_FRACTION_NUMERATOR (z);
- else if (SCM_REALP (z))
- return scm_exact_to_inexact (scm_numerator (scm_inexact_to_exact (z)));
- else
-@@ -5446,10 +5432,7 @@ scm_denominator (SCM z)
- else if (SCM_BIGP (z))
- return SCM_I_MAKINUM (1);
- else if (SCM_FRACTIONP (z))
-- {
-- scm_i_fraction_reduce (z);
-- return SCM_FRACTION_DENOMINATOR (z);
-- }
-+ return SCM_FRACTION_DENOMINATOR (z);
- else if (SCM_REALP (z))
- return scm_exact_to_inexact (scm_denominator (scm_inexact_to_exact (z)));
- else
-Index: libguile/numbers.h
-===================================================================
-RCS file: /cvsroot/guile/guile/guile-core/libguile/numbers.h,v
-retrieving revision 1.103
-diff -p -u -u -r1.103 numbers.h
---- libguile/numbers.h 9 Oct 2006 23:17:57 -0000 1.103
-+++ libguile/numbers.h 23 Dec 2006 20:31:21 -0000
-@@ -157,14 +157,6 @@
- #define SCM_FRACTIONP(x) (!SCM_IMP (x) && SCM_TYP16 (x) == scm_tc16_fraction)
- #define SCM_FRACTION_NUMERATOR(x) (SCM_CELL_OBJECT_1 (x))
- #define SCM_FRACTION_DENOMINATOR(x) (SCM_CELL_OBJECT_2 (x))
--#define SCM_FRACTION_SET_NUMERATOR(x, v) (SCM_SET_CELL_OBJECT_1 ((x), (v)))
--#define SCM_FRACTION_SET_DENOMINATOR(x, v) (SCM_SET_CELL_OBJECT_2 ((x), (v)))
--
-- /* I think the left half word is free in the type, so I'll use bit 17 */
--#define SCM_FRACTION_REDUCED_BIT 0x10000
--#define SCM_FRACTION_REDUCED_SET(x) (SCM_SET_CELL_TYPE((x), (SCM_CELL_TYPE (x) | SCM_FRACTION_REDUCED_BIT)))
--#define SCM_FRACTION_REDUCED_CLEAR(x) (SCM_SET_CELL_TYPE((x), (SCM_CELL_TYPE (x) & ~SCM_FRACTION_REDUCED_BIT)))
--#define SCM_FRACTION_REDUCED(x) (0x10000 & SCM_CELL_TYPE (x))
-
-
-
diff --git a/dev-scheme/guile/files/guile-1.8.1-autotools_fixes.patch b/dev-scheme/guile/files/guile-1.8.1-autotools_fixes.patch
deleted file mode 100644
index 65908c9aa455..000000000000
--- a/dev-scheme/guile/files/guile-1.8.1-autotools_fixes.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- libguile/Makefile.am 2006/11/18 18:14:55 1.209
-+++ libguile/Makefile.am 2007/01/15 23:28:25 1.210
-@@ -285,7 +285,7 @@
- .c.x:
- ./guile-snarf -o $@ $< $(snarfcppopts)
- .c.doc:
-- -(test -n "${AWK+set}" || AWK="@AWK@"; ${AWK} -f ./guile-func-name-check $<)
-+ -$(AWK) -f ./guile-func-name-check $<
- (./guile-snarf-docs $(snarfcppopts) $< | \
- ./guile_filter_doc_snarfage$(EXEEXT) --filter-snarfage) > $@ || { rm $@; false; }
-
---- test-suite/standalone/Makefile.am 2006/02/03 23:38:51 1.13
-+++ test-suite/standalone/Makefile.am 2006/12/02 23:09:03 1.13.2.2
-@@ -29,7 +29,7 @@
-
- TESTS_ENVIRONMENT = "${top_builddir}/pre-inst-guile-env"
-
--test_cflags := \
-+test_cflags = \
- -I$(top_srcdir)/test-suite/standalone \
- -I$(top_srcdir) \
- -I$(top_srcdir)/libguile-ltdl $(EXTRA_DEFS) $(GUILE_CFLAGS)
-@@ -38,7 +38,8 @@
-
- snarfcppopts = \
- $(DEFS) $(DEFAULT_INCLUDES) $(CPPFLAGS) $(CFLAGS) -I$(top_srcdir)
--%.x: %.c
-+SUFFIXES = .x
-+.c.x:
- ${top_builddir}/libguile/guile-snarf -o $@ $< $(snarfcppopts)
-
- CLEANFILES = *.x
---- configure.in 2006/11/29 23:30:43 1.268.2.22
-+++ configure.in 2006/12/02 23:53:16 1.268.2.23
-@@ -68,6 +68,8 @@
- AC_MINIX
-
- AM_PROG_CC_STDC
-+# for per-target cflags in the libguile subdir
-+AM_PROG_CC_C_O
-
- AC_LIBTOOL_DLOPEN
- AC_PROG_LIBTOOL
diff --git a/dev-scheme/guile/files/guile-1.8.1-clog-cexp.patch b/dev-scheme/guile/files/guile-1.8.1-clog-cexp.patch
deleted file mode 100644
index 24ada81d7471..000000000000
--- a/dev-scheme/guile/files/guile-1.8.1-clog-cexp.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Index: guile-1.8.1/configure.in
-===================================================================
---- guile-1.8.1.orig/configure.in
-+++ guile-1.8.1/configure.in
-@@ -602,6 +602,7 @@ AC_CHECK_HEADERS([assert.h crt_externs.h
- # (DINFINITY and DQNAN are actually global variables, not functions)
- # chsize - an MS-DOS-ism, found in mingw
- # clog10 - not in mingw (though others like clog and csqrt are)
-+# clog,cexp - not in FreeBSD (though others are, like cabs)
- # fesetround - available in C99, but not older systems
- # ftruncate - posix, but probably not older systems (current mingw
- # has it as an inline for chsize)
-@@ -614,7 +615,7 @@ AC_CHECK_HEADERS([assert.h crt_externs.h
- # isblank - available as a GNU extension or in C99
- # _NSGetEnviron - Darwin specific
- #
--AC_CHECK_FUNCS([DINFINITY DQNAN chsize clog10 ctermid fesetround ftime ftruncate fchown getcwd geteuid gettimeofday gmtime_r ioctl lstat mkdir mknod nice readdir_r readlink rename rmdir select setegid seteuid setlocale setpgid setsid sigaction siginterrupt stat64 strftime strptime symlink sync sysconf tcgetpgrp tcsetpgrp times uname waitpid strdup system usleep atexit on_exit chown link fcntl ttyname getpwent getgrent kill getppid getpgrp fork setitimer getitimer strchr strcmp index bcopy memcpy rindex truncate unsetenv isblank _NSGetEnviron])
-+AC_CHECK_FUNCS([DINFINITY DQNAN chsize clog10 clog cexp ctermid fesetround ftime ftruncate fchown getcwd geteuid gettimeofday gmtime_r ioctl lstat mkdir mknod nice readdir_r readlink rename rmdir select setegid seteuid setlocale setpgid setsid sigaction siginterrupt stat64 strftime strptime symlink sync sysconf tcgetpgrp tcsetpgrp times uname waitpid strdup system usleep atexit on_exit chown link fcntl ttyname getpwent getgrent kill getppid getpgrp fork setitimer getitimer strchr strcmp index bcopy memcpy rindex truncate unsetenv isblank _NSGetEnviron])
-
- # Reasons for testing:
- # netdb.h - not in mingw
-Index: guile-1.8.1/libguile/numbers.c
-===================================================================
---- guile-1.8.1.orig/libguile/numbers.c
-+++ guile-1.8.1/libguile/numbers.c
-@@ -6018,7 +6018,7 @@ SCM_DEFINE (scm_log, "log", 1, 0, 0,
- {
- if (SCM_COMPLEXP (z))
- {
--#if HAVE_COMPLEX_DOUBLE
-+#if HAVE_COMPLEX_DOUBLE && HAVE_CLOG
- return scm_from_complex_double (clog (SCM_COMPLEX_VALUE (z)));
- #else
- double re = SCM_COMPLEX_REAL (z);
-@@ -6084,7 +6084,7 @@ SCM_DEFINE (scm_exp, "exp", 1, 0, 0,
- {
- if (SCM_COMPLEXP (z))
- {
--#if HAVE_COMPLEX_DOUBLE
-+#if HAVE_COMPLEX_DOUBLE && HAVE_CEXP
- return scm_from_complex_double (cexp (SCM_COMPLEX_VALUE (z)));
- #else
- return scm_c_make_polar (exp (SCM_COMPLEX_REAL (z)),
diff --git a/dev-scheme/guile/files/guile-1.8.1-defaultincludes.patch b/dev-scheme/guile/files/guile-1.8.1-defaultincludes.patch
deleted file mode 100644
index 3adb844f2c32..000000000000
--- a/dev-scheme/guile/files/guile-1.8.1-defaultincludes.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: guile-1.8.1/libguile/Makefile.am
-===================================================================
---- guile-1.8.1.orig/libguile/Makefile.am
-+++ guile-1.8.1/libguile/Makefile.am
-@@ -22,6 +22,7 @@
- AUTOMAKE_OPTIONS = gnu
-
- ## Prevent automake from adding extra -I options
-+DEFAULT_INCLUDES =
- DEFS = @DEFS@
- ## Check for headers in $(srcdir)/.., so that #include
- ## <libguile/MUMBLE.h> will find MUMBLE.h in this dir when we're
diff --git a/dev-scheme/guile/files/guile-amd64.patch b/dev-scheme/guile/files/guile-amd64.patch
deleted file mode 100644
index dc9cea254f05..000000000000
--- a/dev-scheme/guile/files/guile-amd64.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- guile-1.6.4/libguile/gc_os_dep.c 2003-04-16 20:16:21.000000000 +0000
-+++ guile-1.6.4-amd64/libguile/gc_os_dep.c 2003-10-20 01:52:11.543267320 +0000
-@@ -205,6 +205,10 @@
- # define I386
- # define mach_type_known
- # endif
-+# if defined(LINUX) && defined(__x86_64__)
-+# define IA64
-+# define mach_type_known
-+# endif
- # if defined(LINUX) && (defined(__ia64__) || defined(__ia64))
- # define IA64
- # define mach_type_known