summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile/guile-1.8.3-r1.ebuild')
-rw-r--r--dev-scheme/guile/guile-1.8.3-r1.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-scheme/guile/guile-1.8.3-r1.ebuild b/dev-scheme/guile/guile-1.8.3-r1.ebuild
deleted file mode 100644
index 03d96ad11697..000000000000
--- a/dev-scheme/guile/guile-1.8.3-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.3-r1.ebuild,v 1.2 2009/07/31 17:26:07 ssuominen Exp $
-
-EAPI=1
-inherit eutils autotools flag-o-matic
-
-DESCRIPTION="Scheme interpreter"
-HOMEPAGE="http://www.gnu.org/software/guile/"
-SRC_URI="mirror://gnu/guile/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-
-DEPEND=">=dev-libs/gmp-4.1 >=sys-devel/libtool-1.5.6 sys-devel/gettext"
-
-# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
-# but there are lots of collisions. Most in /usr/share/libguile. Therefore
-# I'm slotting this in the same slot as guile-1.6* for now.
-SLOT="12"
-MAJOR="1.8"
-
-IUSE="networking +regex discouraged +deprecated elisp nls debug-freelist debug-malloc debug +threads"
-
-src_unpack() {
- unpack ${A}; cd "${S}"
-
- epatch "${FILESDIR}"/fix-reader-cr.diff
-
- sed "s_sleep 999_sleep 1_" -i test-suite/tests/popen.test
-}
-
-src_compile() {
- # see bug #178499
- filter-flags -ftree-vectorize
-
-#will fail for me if posix is disabled or without modules -- hkBst
- econf \
- --disable-error-on-warning \
- --disable-static \
- --enable-posix \
- $(use_enable networking) \
- $(use_enable regex) \
- $(use deprecated || use_enable discouraged) \
- $(use_enable deprecated) \
- $(use_enable elisp) \
- $(use_enable nls) \
- --disable-rpath \
- $(use_enable debug-freelist) \
- $(use_enable debug-malloc) \
- $(use_enable debug guile-debug) \
- $(use_with threads) \
- --with-modules
-
- emake || die "make failed"
-}
-
-src_install() {
- einstall || die "install failed"
-
- dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS
-
- # texmacs needs this, closing bug #23493
- dodir /etc/env.d
- echo "GUILE_LOAD_PATH=\"/usr/share/guile/${MAJOR}\"" > "${D}"/etc/env.d/50guile
-}