summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/molecule/molecule-0.9.6.3.ebuild')
-rw-r--r--dev-util/molecule/molecule-0.9.6.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/molecule/molecule-0.9.6.3.ebuild b/dev-util/molecule/molecule-0.9.6.3.ebuild
new file mode 100644
index 000000000000..8a24d6146b56
--- /dev/null
+++ b/dev-util/molecule/molecule-0.9.6.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/molecule-0.9.6.3.ebuild,v 1.1 2010/06/28 14:07:54 lxnay Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit eutils multilib python base
+
+DESCRIPTION="Release metatool used for creating Sabayon (and Gentoo) releases"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="http://distfiles.sabayon.org/dev-util/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+doc"
+
+DEPEND="${DEPEND}
+ sys-devel/gettext"
+RDEPEND="${RDEPEND}
+ app-cdr/cdrtools
+ net-misc/rsync
+ sys-fs/squashfs-tools"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install \
+ || die "emake install failed"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/molecule"
+}