summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/tla/tla-1.1_pre7.ebuild')
-rw-r--r--dev-util/tla/tla-1.1_pre7.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/tla/tla-1.1_pre7.ebuild b/dev-util/tla/tla-1.1_pre7.ebuild
new file mode 100644
index 000000000000..7aaf1d9ea8b9
--- /dev/null
+++ b/dev-util/tla/tla-1.1_pre7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/tla/tla-1.1_pre7.ebuild,v 1.1 2003/10/20 04:53:41 rphillips Exp $
+
+MY_P="${P/_/}"
+
+S="${WORKDIR}/${MY_P}/src/=build"
+DESCRIPTION="Revision control system ideal for widely distributed development"
+SRC_URI="http://arch.quackerhead.com/~lord/releases/tla/${MY_P}.tar.gz"
+HOMEPAGE="http://arch.quackerhead.com/~lord/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc ~mips ~hppa ~sparc ~arm"
+
+DEPEND="sys-apps/coreutils
+ sys-apps/diffutils
+ sys-devel/patch
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/tar
+ sys-apps/util-linux
+ sys-apps/debianutils
+ sys-devel/make"
+
+src_unpack() {
+ unpack "${A}"
+ mkdir "${MY_P}/src/=build"
+}
+
+src_compile() {
+ ../configure \
+ --prefix="/usr" \
+ --with-posix-shell="/bin/bash" || die "configure failed"
+ # parallel make may cause problems with this package
+ make || die "make failed"
+}
+
+src_install () {
+ make install prefix="${D}/usr" \
+ || die "make install failed"
+ cd ${WORKDIR}/${MY_P}/src
+ dodoc COPYING
+ cd docs-tla
+ dodoc =README
+ cd html
+ dohtml -r .
+}