summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/mutantstormdemo')
-rw-r--r--games-action/mutantstormdemo/ChangeLog8
-rw-r--r--games-action/mutantstormdemo/Manifest3
-rw-r--r--games-action/mutantstormdemo/files/digest-mutantstormdemo-11
-rw-r--r--games-action/mutantstormdemo/mutantstormdemo-1.ebuild36
4 files changed, 48 insertions, 0 deletions
diff --git a/games-action/mutantstormdemo/ChangeLog b/games-action/mutantstormdemo/ChangeLog
new file mode 100644
index 000000000000..fba9e7c85d32
--- /dev/null
+++ b/games-action/mutantstormdemo/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-games/mutantstormdemo
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstormdemo/ChangeLog,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+*mutantstormdemo-1 (07 Jul 2003)
+
+ 07 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-action/mutantstormdemo/Manifest b/games-action/mutantstormdemo/Manifest
new file mode 100644
index 000000000000..2cafc71f0c19
--- /dev/null
+++ b/games-action/mutantstormdemo/Manifest
@@ -0,0 +1,3 @@
+MD5 6e18d3b14a24232ac4edab23816653d1 files/digest-mutantstormdemo-1 64
+MD5 9f43fef56163bfade8234ff026b075c6 ChangeLog 361
+MD5 1fc36f65d01a467665327ff4b8d57c09 mutantstormdemo-1.ebuild 852
diff --git a/games-action/mutantstormdemo/files/digest-mutantstormdemo-1 b/games-action/mutantstormdemo/files/digest-mutantstormdemo-1
new file mode 100644
index 000000000000..cfa9d6f9934d
--- /dev/null
+++ b/games-action/mutantstormdemo/files/digest-mutantstormdemo-1
@@ -0,0 +1 @@
+MD5 5c7120640a002482607fd5c838dcc02e mutantstormdemo.sh 8385054
diff --git a/games-action/mutantstormdemo/mutantstormdemo-1.ebuild b/games-action/mutantstormdemo/mutantstormdemo-1.ebuild
new file mode 100644
index 000000000000..298c2704a798
--- /dev/null
+++ b/games-action/mutantstormdemo/mutantstormdemo-1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstormdemo/mutantstormdemo-1.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="shoot through crazy psychedelic 3D environments"
+HOMEPAGE="http://www.pompom.org.uk/"
+SRC_URI="http://www.btinternet.com/%7Ebongpig/${PN}.sh"
+
+LICENSE="POMPOM"
+SLOT="0"
+KEYWORDS="-* x86"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir} ${GAMES_BINDIR}
+
+ cp -r menu script styles ${D}/${dir}/
+
+ exeinto ${dir}
+ doexe bin/x86/*
+ dosed "s:XYZZY:${dir}:" ${dir}/${PN}
+ dosym ${dir}/${PN} ${GAMES_BINDIR}/${PN}
+
+ insinto ${dir}
+ doins pompom README buy_me icon.xpm instructions.htm license.txt
+
+ prepgamesdirs
+}