summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/xboing')
-rw-r--r--games-arcade/xboing/ChangeLog20
-rw-r--r--games-arcade/xboing/Manifest3
-rw-r--r--games-arcade/xboing/files/digest-xboing-2.4-r12
-rw-r--r--games-arcade/xboing/xboing-2.4-r1.ebuild48
4 files changed, 73 insertions, 0 deletions
diff --git a/games-arcade/xboing/ChangeLog b/games-arcade/xboing/ChangeLog
new file mode 100644
index 000000000000..b59d157b6bfd
--- /dev/null
+++ b/games-arcade/xboing/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for app-games/xboing
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xboing/ChangeLog,v 1.1 2003/09/10 19:29:22 vapier Exp $
+
+*xboing-2.4-r1 (20 Jun 2003)
+
+ 20 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Removed script and added a debian patch to fix all known issues.
+
+*xboing-2.4 (03 Mar 2003)
+
+ 19 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added a playxboing script because of e-mail from
+ Ryan Beasley <ryanb@goddamnbastard.org>. thanks ;)
+
+ 12 Jun 2003; Seemant Kulleen <seemant@gentoo.org> xboing-2.4.ebuild:
+ xpm is provided by xfree
+
+ 03 Mar 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me for #13515.
diff --git a/games-arcade/xboing/Manifest b/games-arcade/xboing/Manifest
new file mode 100644
index 000000000000..397f3d03c453
--- /dev/null
+++ b/games-arcade/xboing/Manifest
@@ -0,0 +1,3 @@
+MD5 b75a2764405600a86ace54104e9e3259 xboing-2.4-r1.ebuild 1115
+MD5 1624963aea6e3f0dfabfb6d9a447c942 files/digest-xboing-2.4-r1 131
+MD5 9bafb735bdabf0ec0852548c8185ae47 ChangeLog 754
diff --git a/games-arcade/xboing/files/digest-xboing-2.4-r1 b/games-arcade/xboing/files/digest-xboing-2.4-r1
new file mode 100644
index 000000000000..cb5c763d45e2
--- /dev/null
+++ b/games-arcade/xboing/files/digest-xboing-2.4-r1
@@ -0,0 +1,2 @@
+MD5 d596d29e53cf0deceb18f3b646787709 xboing2.4.tar.gz 588811
+MD5 b0567f3833c7c2152cce8526b06e07cf xboing-2.4-debian.patch.bz2 7740
diff --git a/games-arcade/xboing/xboing-2.4-r1.ebuild b/games-arcade/xboing/xboing-2.4-r1.ebuild
new file mode 100644
index 000000000000..82724dbfc484
--- /dev/null
+++ b/games-arcade/xboing/xboing-2.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xboing/xboing-2.4-r1.ebuild,v 1.1 2003/09/10 19:29:22 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="blockout type game where you bounce a proton ball trying to destroy blocks"
+HOMEPAGE="http://www.techrescue.org/xboing/"
+SRC_URI="http://www.techrescue.org/xboing/${PN}${PV}.tar.gz
+ mirror://gentoo/xboing-${PV}-debian.patch.bz2"
+
+LICENSE="xboing"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/xboing-${PV}-debian.patch
+}
+
+src_compile() {
+ xmkmf -a || die
+ cp Imakefile{,.orig}
+ sed -e "s:GENTOO_VER:${PF/${PN}-/}:" \
+ Imakefile.orig > Imakefile
+ emake \
+ CXXOPTIONS="${CXXFLAGS}" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ XBOING_DIR=${GAMES_DATADIR}/${PN} \
+ || die
+}
+
+src_install() {
+ make \
+ PREFIX=${D} \
+ XBOING_DIR=${GAMES_DATADIR}/${PN} \
+ install \
+ || die
+ fperms 660 ${GAMES_STATEDIR}/xboing.score
+ newman xboing.man xboing.6
+ dodoc README docs/*.doc
+ prepgamesdirs
+}