summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/iagno/iagno-3.14.2.ebuild')
-rw-r--r--games-board/iagno/iagno-3.14.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-board/iagno/iagno-3.14.2.ebuild b/games-board/iagno/iagno-3.14.2.ebuild
new file mode 100644
index 000000000000..06675138eef0
--- /dev/null
+++ b/games-board/iagno/iagno-3.14.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/iagno/iagno-3.14.2.ebuild,v 1.1 2014/12/22 18:54:07 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.24"
+
+inherit gnome-games vala
+
+DESCRIPTION="Dominate the board in a classic version of Reversi"
+HOMEPAGE="https://wiki.gnome.org/Apps/Iagno"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ >=gnome-base/librsvg-2.32.0
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/gtk+-3.12:3
+"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-themes/gnome-themes-standard-3.14
+"
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-util/appdata-tools
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome-games_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ gnome-games_src_configure APPDATA_VALIDATE=$(type -P true)
+}