summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/pcsx2/pcsx2-0.8.1.ebuild')
-rw-r--r--games-emulation/pcsx2/pcsx2-0.8.1.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/games-emulation/pcsx2/pcsx2-0.8.1.ebuild b/games-emulation/pcsx2/pcsx2-0.8.1.ebuild
index d048c1739279..92d84f1db9c5 100644
--- a/games-emulation/pcsx2/pcsx2-0.8.1.ebuild
+++ b/games-emulation/pcsx2/pcsx2-0.8.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.8.1.ebuild,v 1.1 2005/08/04 04:49:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.8.1.ebuild,v 1.2 2005/08/07 07:49:02 vapier Exp $
-inherit eutils games
+inherit games eutils toolchain-funcs
DESCRIPTION="Playstation2 emulator"
HOMEPAGE="http://www.pcsx2.net/"
@@ -10,7 +10,7 @@ SRC_URI="http://www.pcsx2.net/download/0.8release/${P}src.7z"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="virtual/x11
@@ -19,9 +19,9 @@ RDEPEND="virtual/x11
>=games-emulation/ps2emu-cddvdlinuz-0.3-r1
>=games-emulation/ps2emu-cdvdiso-0.3
)
- >=games-emulation/ps2emu-gssoft-0.61
+ >=games-emulation/ps2emu-gssoft-0.6.1
>=games-emulation/ps2emu-padxwin-0.5
- >=games-emulation/ps2emu-spu2null-0.21
+ >=games-emulation/ps2emu-spu2null-0.2.1
>=games-emulation/ps2emu-dev9null-0.1"
DEPEND="${RDEPEND}
app-arch/p7zip"
@@ -29,11 +29,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}src
src_unpack() {
- cd "${WORKDIR}"
7z x "${DISTDIR}/${P}src.7z" || die "unpack failed"
cd "${S}"
+ epatch "${FILESDIR}"/${P}-amd64.patch
sed -i \
- -e "/^CC/d" \
+ -e '/^CC/d' \
+ -e "/^CPU/s:=.*:=$(tc-arch-kernel):" \
Linux/Makefile \
|| die "sed failed"
sed -i \
@@ -55,5 +56,7 @@ src_install() {
"${D}/${GAMES_BINDIR}/pcsx2" \
|| die "sed failed"
dodoc Docs/*.txt
+ doicon "${FILESDIR}"/pcsx2.png
+ make_desktop_entry pcsx2 PCSX2 pcsx2.png
prepgamesdirs
}