summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/yadex/yadex-1.7.0.ebuild')
-rw-r--r--games-misc/yadex/yadex-1.7.0.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/games-misc/yadex/yadex-1.7.0.ebuild b/games-misc/yadex/yadex-1.7.0.ebuild
index d011450de037..483eadf80d6f 100644
--- a/games-misc/yadex/yadex-1.7.0.ebuild
+++ b/games-misc/yadex/yadex-1.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/yadex/yadex-1.7.0.ebuild,v 1.6 2006/04/03 17:34:09 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/yadex/yadex-1.7.0.ebuild,v 1.7 2006/06/25 00:12:34 mr_bones_ Exp $
inherit games
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc x86"
IUSE=""
+RESTRICT="test"
DEPEND="|| ( x11-libs/libX11 virtual/x11 )"
@@ -19,11 +20,11 @@ src_unpack() {
unpack ${A}
sed -i \
-e '/iwad/s/local\///' \
- ${S}/yadex.cfg \
+ "${S}"/yadex.cfg \
|| die "sed yadex.cfg failed"
epatch "${FILESDIR}/${P}"-NULL-is-not-zero.patch
# Force the patched file to be old, otherwise the compile fails
- touch -t 196910101010 ${S}/src/wadlist.cc
+ touch -t 196910101010 "${S}"/src/wadlist.cc
}
src_compile() {
@@ -34,13 +35,12 @@ src_compile() {
src_install() {
dogamesbin obj/0/yadex || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}/${PV}/"
+ insinto "${GAMES_DATADIR}/${PN}/${PV}"
doins ygd/* || die "doins failed (data)"
doman doc/yadex.6
dodoc CHANGES FAQ README TODO VERSION
dohtml doc/*
- insinto /etc/yadex/${PV}/
- doins yadex.cfg || die "doins failed (cfg)"
-
+ insinto /etc/yadex/${PV}
+ doins yadex.cfg || die "doins failed (cfg)"
prepgamesdirs
}