summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-server/cyphesis/files/cyphesis-0.5.15-gentoo.patch')
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.15-gentoo.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-server/cyphesis/files/cyphesis-0.5.15-gentoo.patch b/games-server/cyphesis/files/cyphesis-0.5.15-gentoo.patch
new file mode 100644
index 000000000000..b7b4fa543e60
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.5.15-gentoo.patch
@@ -0,0 +1,40 @@
+--- configure.ac.old 2007-01-31 23:22:11.000000000 +0100
++++ configure.ac 2007-01-31 23:22:40.000000000 +0100
+@@ -258,26 +258,6 @@
+ AC_MSG_ERROR([Cannot find valid versions of required WorldForge maths library, wfmath. Please see http://worldforge.org/dev/eng/servers/cyphesis for details of the libraries required and where to obtain them.])
+ ])
+
+-PKG_CHECK_MODULES(AVAHI, avahi-client,
+- [
+- CPPFLAGS="$CPPFLAGS $AVAHI_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $AVAHI_LIBS"
+- AC_DEFINE(HAVE_AVAHI, 1, [Define to 1 if you have avahi libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- PKG_CHECK_MODULES(HOWL, howl,
+- [
+- CPPFLAGS="$CPPFLAGS $HOWL_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $HOWL_LIBS"
+- AC_DEFINE(HAVE_LIBHOWL, 1, [Define to 1 if you have howl libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- AC_MSG_NOTICE([Ommiting DNS-SD functionality.])
+- ])
+- ])
+-
+ AM_PATH_PSQL(7.1.0,
+ [
+ if test "$PG_CFLAGS" != "-I/usr/include"; then
+--- rulesets/Makefile.am.old 2007-11-03 11:56:49.000000000 +0100
++++ rulesets/Makefile.am 2007-11-03 11:57:10.000000000 +0100
+@@ -4,7 +4,7 @@
+
+ RULESETS = basic/mind mason
+
+-moduledir = $(DESTDIR)$(datadir)/cyphesis/scripts/cyphesis
++moduledir = $(datadir)/cyphesis/scripts/cyphesis
+ dist_module_DATA = basic/__init__.py \
+ basic/world/objects/Thing.py \
+ basic/world/probability.py \