summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/naev')
-rw-r--r--games-strategy/naev/ChangeLog8
-rw-r--r--games-strategy/naev/naev-0.5.0.ebuild (renamed from games-strategy/naev/naev-0.5.0_beta2.ebuild)20
2 files changed, 15 insertions, 13 deletions
diff --git a/games-strategy/naev/ChangeLog b/games-strategy/naev/ChangeLog
index 90b8e4293c09..52ca367b4a46 100644
--- a/games-strategy/naev/ChangeLog
+++ b/games-strategy/naev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/naev
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/ChangeLog,v 1.4 2011/05/29 10:06:39 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/ChangeLog,v 1.5 2011/06/04 16:54:26 hwoarang Exp $
+
+*naev-0.5.0 (04 Jun 2011)
+
+ 04 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -naev-0.5.0_beta2.ebuild,
+ +naev-0.5.0.ebuild:
+ Version bump thanks to Samuli Suominen <ssuominen@gentoo.org>
*naev-0.5.0_beta2 (29 May 2011)
diff --git a/games-strategy/naev/naev-0.5.0_beta2.ebuild b/games-strategy/naev/naev-0.5.0.ebuild
index e53f2a812828..0e949de1c748 100644
--- a/games-strategy/naev/naev-0.5.0_beta2.ebuild
+++ b/games-strategy/naev/naev-0.5.0.ebuild
@@ -1,17 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/naev-0.5.0_beta2.ebuild,v 1.2 2011/05/29 23:17:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/naev-0.5.0.ebuild,v 1.1 2011/06/04 16:54:26 hwoarang Exp $
EAPI=2
-inherit gnome2-utils eutils games
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-${MY_PV}
+inherit gnome2-utils games
DESCRIPTION="A 2D space trading and combat game, in a similar vein to Escape Velocity"
HOMEPAGE="http://code.google.com/p/naev/"
-SRC_URI="http://naev.googlecode.com/files/${MY_P}.tar.bz2
- http://naev.googlecode.com/files/ndata-${MY_PV}"
+SRC_URI="mirror://sourceforge/naev/${P}.tar.bz2
+ mirror://sourceforge/naev/ndata-${PV}"
LICENSE="GPL-2 GPL-3 public-domain CCPL-Attribution-3.0 CCPL-Attribution-ShareAlike-3.0"
SLOT="0"
@@ -31,10 +28,8 @@ RDEPEND="media-libs/libsdl[X,audio,video]
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-S=${WORKDIR}/${MY_P}
-
src_unpack() {
- unpack ${MY_P}.tar.bz2
+ unpack ${P}.tar.bz2
}
src_configure() {
@@ -54,7 +49,7 @@ src_install() {
install || die
insinto "${GAMES_DATADIR}"/${PN}
- newins "${DISTDIR}"/ndata-${MY_PV} ndata || die
+ newins "${DISTDIR}"/ndata-${PV} ndata || die
local res
for res in 16 64 128 256; do
@@ -62,7 +57,8 @@ src_install() {
newins extras/logos/logo${res}.png naev.png || die
done
- domenu naev.desktop
+ rm -f "${D}"/usr/share/doc/${PF}/LICENSE
+ prepalldocs
prepgamesdirs
}