summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/wesnoth/wesnoth-0.9.4.ebuild')
-rw-r--r--games-strategy/wesnoth/wesnoth-0.9.4.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/games-strategy/wesnoth/wesnoth-0.9.4.ebuild b/games-strategy/wesnoth/wesnoth-0.9.4.ebuild
deleted file mode 100644
index 1b075cb2df31..000000000000
--- a/games-strategy/wesnoth/wesnoth-0.9.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.9.4.ebuild,v 1.2 2005/08/19 05:14:41 mr_bones_ Exp $
-
-inherit eutils toolchain-funcs flag-o-matic games
-
-DESCRIPTION="A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE="editor gnome kde lite nls server tools"
-
-DEPEND=">=media-libs/libsdl-1.2.7
- >=media-libs/sdl-image-1.2
- >=media-libs/sdl-mixer-1.2
- >=media-libs/freetype-2
- media-libs/sdl-net
- sys-libs/zlib
- virtual/x11"
-
-src_compile() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- fi
- egamesconf \
- --disable-dependency-tracking \
- $(use_enable lite) \
- $(use_enable server) \
- $(use_enable server campaign-server) \
- $(use_enable editor) \
- $(use_enable tools) \
- $(use_enable nls) \
- $(use_with gnome) \
- $(use_with kde) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
- dodoc MANUAL changelog
- prepgamesdirs
-}