summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/ORBit/ORBit-0.5.14-r1.ebuild')
-rw-r--r--gnome-base/ORBit/ORBit-0.5.14-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnome-base/ORBit/ORBit-0.5.14-r1.ebuild b/gnome-base/ORBit/ORBit-0.5.14-r1.ebuild
new file mode 100644
index 000000000000..a90ba681b555
--- /dev/null
+++ b/gnome-base/ORBit/ORBit-0.5.14-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.14-r1.ebuild,v 1.1 2002/03/27 23:09:40 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A high-performance, lightweight CORBA ORB aiming for CORBA 2.2 compliance"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.labs.redhat.com/orbit/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-apps/tcp-wrappers-7.6
+ >=dev-libs/glib-1.2.8"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.8"
+
+
+src_compile() {
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ # Libtoolize to fix "relink bug" in older libtool's distributed
+ # with packages.
+ libtoolize --copy --force
+ aclocal
+ autoconf
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dodoc docs/*.txt docs/IDEA1
+
+ docinto idl
+ cd libIDL
+ dodoc AUTHORS BUGS COPYING NEWS README*
+
+ docinto popt
+ cd ../popt
+ dodoc CHANGES COPYING README
+
+ cd ${D}/usr/lib
+ patch -p0 < ${FILESDIR}/libIDLConf.sh-gentoo.diff
+}
+