summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/ChangeLog7
-rw-r--r--gnome-extra/libgda/Manifest4
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.12.11
-rw-r--r--gnome-extra/libgda/libgda-0.12.1.ebuild95
4 files changed, 104 insertions, 3 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index 1df7926d0091..3da550ef583d 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/libgda
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.19 2003/06/03 10:30:09 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.20 2003/06/16 09:39:49 liquidx Exp $
+
+*libgda-0.12.1 (16 Jun 2003)
+
+ 16 Jun 2003; Alastair Tse <liquidx@gentoo.org> libgda-0.12.1.ebuild:
+ new gnomedb release
*libgda-0.12.0 (03 Jun 2003)
diff --git a/gnome-extra/libgda/Manifest b/gnome-extra/libgda/Manifest
index d2c4d1bd133b..3da04752dd30 100644
--- a/gnome-extra/libgda/Manifest
+++ b/gnome-extra/libgda/Manifest
@@ -1,8 +1,8 @@
-MD5 866e839c7240d81edc7b1067dcc45792 ChangeLog 3195
+MD5 764f90376af95e3310e691f2a778512d ChangeLog 3319
MD5 5ab82f7dadae03ca71999d11372c5569 libgda-0.2.95-r1.ebuild 3309
MD5 0706eb893fe1650972a01bf901cbd3ce libgda-0.12.0.ebuild 2425
MD5 8f9f7b7c7813c4a410bdabf61cb18ddb libgda-0.2.96-r2.ebuild 3513
-MD5 0706eb893fe1650972a01bf901cbd3ce libgda-0.12.1.ebuild 2425
+MD5 671b9cf742c73f2b54e960d74ae9eee9 libgda-0.12.1.ebuild 2425
MD5 358ffa5bf7e7cc07a199014c693c9ee1 libgda-0.11.0.ebuild 2514
MD5 40bbf8acf6e08a15e8e61573f6f07724 files/digest-libgda-0.2.95-r1 66
MD5 f304a410c4ca5df624d99703eb7b1dfc files/digest-libgda-0.12.0 66
diff --git a/gnome-extra/libgda/files/digest-libgda-0.12.1 b/gnome-extra/libgda/files/digest-libgda-0.12.1
new file mode 100644
index 000000000000..afbe137e9977
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-0.12.1
@@ -0,0 +1 @@
+MD5 d98597ca9746d36db8e455ce7de48ac0 libgda-0.12.1.tar.bz2 902974
diff --git a/gnome-extra/libgda/libgda-0.12.1.ebuild b/gnome-extra/libgda/libgda-0.12.1.ebuild
new file mode 100644
index 000000000000..411223c6f5cf
--- /dev/null
+++ b/gnome-extra/libgda/libgda-0.12.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-0.12.1.ebuild,v 1.1 2003/06/16 09:39:49 liquidx Exp $
+
+IUSE="odbc postgres mysql ldap firebird freetds sqlite mdb oci8"
+
+inherit gnome2 gnome.org
+
+DESCRIPTION="Gnome Database Access Library"
+HOMEPAGE="http://www.gnome-db.org/"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND=">=gnome-base/ORBit2-2.3.91
+ >=dev-libs/glib-2.0.4
+ >=gnome-base/bonobo-activation-0.7.0
+ >=gnome-base/libbonobo-2.0.0
+ >=dev-libs/libxml2-2.4.23
+ >=gnome-base/gconf-1.2.0
+ >=dev-libs/libxslt-1.0.9
+ >=gnome-base/gnome-vfs-2.0.0
+ dev-libs/popt
+ sys-libs/readline
+ sys-libs/ncurses
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ postgres? ( >=dev-db/postgresql-7.2.1 )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ firebird? ( >=dev-db/firebird-1.0 )
+ freetds? ( >=dev-db/freetds-0.5 )
+ sqlite? ( >=dev-db/sqlite-2.4.2 )
+ mdb? ( >=app-office/mdbtools-0.5 )"
+
+DEPEND=">=dev-util/pkgconfig-0.8
+ >=dev-util/intltool-0.22
+ >=sys-devel/gettext-0.11
+ app-text/scrollkeeper
+ ${RDEPEND}"
+
+# problems with parallel builds
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ gnome2_omf_fix ${S}/doc/Makefile.in
+}
+
+src_compile() {
+
+ local myconf
+
+ use mysql \
+ && myconf="${myconf} --with-mysql=/usr" \
+ || myconf="${myconf} --without-mysql"
+
+ use postgres \
+ && myconf="${myconf} --with-postgres=/usr" \
+ || myconf="${myconf} --without-postgres"
+
+ use odbc \
+ && myconf="${myconf} --with-odbc=/usr" \
+ || myconf="${myconf} --without-odbc"
+
+ use ldap \
+ && myconf="${myconf} --with-ldap=/usr" \
+ || myconf="${myconf} --without-ldap"
+
+ use sqlite \
+ && myconf="$myconf --with-sqlite=/usr" \
+ || myconf="$myconf --without-sqlite"
+
+ use freetds \
+ && myconf="$myconf --with-tds=/usr" \
+ || myconf="$myconf --without-tds"
+
+ use firebird \
+ && myconf="${myconf} --with-firebird=/usr" \
+ || myconf="${myconf} --without-firebird"
+
+ use mdb \
+ && myconf="${myconf} --with-mdb=/usr" \
+ || myconf="${myconf} --without-mdb"
+
+ # not in portage (http://linux.techass.com/projects/xdb/)
+ myconf="${myconf} --without-xbase"
+ myconf="${myconf} --without-msql"
+
+ # closed source dbs
+ myconf="${myconf} --without-ibmdb2"
+ myconf="${myconf} --without-sybase"
+ use oci8 || myconf="${myconf} --without-oracle"
+
+ gnome2_src_compile ${myconf}
+}