summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kalgebra/kalgebra-4.6.4.ebuild')
-rw-r--r--kde-base/kalgebra/kalgebra-4.6.4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/kde-base/kalgebra/kalgebra-4.6.4.ebuild b/kde-base/kalgebra/kalgebra-4.6.4.ebuild
new file mode 100644
index 000000000000..08c6824eddd9
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.6.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.6.4.ebuild,v 1.1 2011/06/10 17:59:49 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeedu"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma readline"
+
+DEPEND="
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/LibKdeEduConfig.cmake.in
+"
+KMEXTRA="
+ libkdeedu/qtmmlwidget/
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.5.73-solaris-graph2d.patch
+ "${FILESDIR}"/${PN}-4.6.4-nolib.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with readline)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test
+ sed -i -e '/mathmlpresentationtest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/analitza/tests/CMakeLists.txt || \
+ die "sed to disable mathmlpresentationtest failed."
+
+ kde4-meta_src_test
+}