summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdegraphics/kdegraphics-3.3.0_beta2.ebuild')
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.3.0_beta2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-base/kdegraphics/kdegraphics-3.3.0_beta2.ebuild b/kde-base/kdegraphics/kdegraphics-3.3.0_beta2.ebuild
new file mode 100644
index 000000000000..13435f31d1b3
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.3.0_beta2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.3.0_beta2.ebuild,v 1.1 2004/07/26 14:34:29 caleb Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE graphics-related apps"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="gphoto2 tetex scanner opengl"
+
+DEPEND="~kde-base/kdebase-${PV}
+ gphoto2? ( media-gfx/gphoto2 )
+ scanner? ( media-gfx/sane-backends )
+ tetex? ( virtual/tetex )
+ dev-libs/fribidi
+ opengl? ( virtual/glut virtual/opengl )
+ media-libs/imlib
+ virtual/ghostscript
+ media-libs/tiff
+ x86? ( scanner? sys-libs/libieee1284 )"
+RDEPEND="${DEPEND}
+ app-text/xpdf"
+
+src_unpack() {
+ kde_src_unpack
+}
+
+src_compile() {
+
+ use gphoto2 \
+ && myconf="$myconf --with-kamera \
+ --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2" \
+ || myconf="$myconf --without-kamera"
+
+ use tetex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+
+ use scanner || DO_NOT_COMPILE="$DO_NOT_COMPILE kooka libkscan"
+
+ myconf="$myconf --with-imlib --with-imlib-config=/usr/bin"
+ kde_src_compile
+}