summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdepim-common-libs')
-rw-r--r--kde-base/kdepim-common-libs/ChangeLog8
-rw-r--r--kde-base/kdepim-common-libs/files/install-composereditorng.patch15
-rw-r--r--kde-base/kdepim-common-libs/kdepim-common-libs-4.11.0.ebuild70
3 files changed, 92 insertions, 1 deletions
diff --git a/kde-base/kdepim-common-libs/ChangeLog b/kde-base/kdepim-common-libs/ChangeLog
index 9df058552830..ebfa71b2907c 100644
--- a/kde-base/kdepim-common-libs/ChangeLog
+++ b/kde-base/kdepim-common-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim-common-libs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/ChangeLog,v 1.104 2013/08/02 17:20:54 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/ChangeLog,v 1.105 2013/08/14 20:24:04 dilfridge Exp $
+
+*kdepim-common-libs-4.11.0 (14 Aug 2013)
+
+ 14 Aug 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kdepim-common-libs-4.11.0.ebuild, +files/install-composereditorng.patch:
+ Version bump KDE SC 4.11.0
02 Aug 2013; Johannes Huber <johu@gentoo.org>
-kdepim-common-libs-4.10.4.ebuild:
diff --git a/kde-base/kdepim-common-libs/files/install-composereditorng.patch b/kde-base/kdepim-common-libs/files/install-composereditorng.patch
new file mode 100644
index 000000000000..e0847dc0e714
--- /dev/null
+++ b/kde-base/kdepim-common-libs/files/install-composereditorng.patch
@@ -0,0 +1,15 @@
+--- composereditor-ng/CMakeLists.txt 2013-02-25 03:16:44.129528884 +0000
++++ composereditor-ng/CMakeLists.txt.new 2013-02-25 03:18:48.016192479 +0000
+@@ -58,8 +58,8 @@
+ install(TARGETS composereditorng ${INSTALL_TARGETS_DEFAULT_ARGS} )
+ install( FILES data/composereditorinitialhtml DESTINATION ${DATA_INSTALL_DIR}/composereditor )
+
+-#install( FILES
+-# composereditor_export.h
+-# composereditor.h
+-# DESTINATION ${INCLUDE_INSTALL_DIR}/composereditorng COMPONENT Devel )
++install( FILES
++ composereditor_export.h
++ composereditor.h
++ DESTINATION ${INCLUDE_INSTALL_DIR}/composereditorng COMPONENT Devel )
+
diff --git a/kde-base/kdepim-common-libs/kdepim-common-libs-4.11.0.ebuild b/kde-base/kdepim-common-libs/kdepim-common-libs-4.11.0.ebuild
new file mode 100644
index 000000000000..14faf61fd065
--- /dev/null
+++ b/kde-base/kdepim-common-libs/kdepim-common-libs-4.11.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/kdepim-common-libs-4.11.0.ebuild,v 1.1 2013/08/14 20:24:04 dilfridge Exp $
+
+EAPI=5
+
+KMNAME="kdepim"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Common libraries for KDE PIM apps"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ app-crypt/gpgme
+ >=app-office/akonadi-server-1.9.52
+ dev-libs/grantlee
+ >=dev-libs/shared-desktop-ontologies-0.11.0
+ $(add_kdebase_dep kdepimlibs)
+"
+RDEPEND="${DEPEND}
+ !kde-base/akonadi:4
+ !kde-base/libkdepim:4
+ !kde-base/libkleo:4
+ !kde-base/libkpgp:4
+ !<kde-base/kaddressbook-4.4.90:4
+ !kde-base/kdepim-wizards:4
+ !<kde-base/kmail-4.4.80:4
+ !<kde-base/korganizer-4.5.67:4
+ !<kde-base/kmail-4.10.95:4
+ app-crypt/gnupg
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+RESTRICT="test"
+# bug 393131
+
+KMEXTRA="
+ akonadi_next/
+ calendarsupport/
+ calendarviews/
+ composereditor-ng/
+ incidenceeditor-ng/
+ libkdepim/
+ libkdepimdbusinterfaces/
+ libkleo/
+ libkpgp/
+ kdgantt2/
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ ontologies/
+ pimcommon/
+ sendlateragent/
+ templateparser/
+"
+
+KMEXTRACTONLY="
+ kleopatra/
+ kmail/
+ knode/org.kde.knode.xml
+ korganizer/korgac/org.kde.korganizer.KOrgac.xml
+ korganizer/org.kde.korganizer.Korganizer.xml
+"
+
+KMSAVELIBS="true"
+
+PATCHES=( "${FILESDIR}/install-composereditorng.patch" )