summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/libkworkspace/libkworkspace-4.1.3.ebuild')
-rw-r--r--kde-base/libkworkspace/libkworkspace-4.1.3.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild b/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild
index 0019d42f266a..7b86d0d6e720 100644
--- a/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild
+++ b/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild,v 1.1 2008/11/09 02:51:33 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild,v 1.2 2008/11/09 13:40:34 scarabeus Exp $
EAPI="2"
@@ -13,6 +13,14 @@ DESCRIPTION="A library for KDE desktop applications"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
+KMEXTRA="cmake"
KMEXTRACTONLY="ksmserver/org.kde.KSMServerInterface.xml
kwin/org.kde.KWin.xml"
KMSAVELIBS="true"
+
+src_prepare() {
+ # install cmake modules here
+ sed -i \
+ -e "s/^#DONOTINSTALL //" \
+ cmake/modules/CMakeLists.txt || die "sed failed"
+}