summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kcontrol/ChangeLog8
-rw-r--r--kde-base/kcontrol/files/digest-kcontrol-3.4.1-r13
-rw-r--r--kde-base/kcontrol/files/kdebase-3.4.1-configure.patch84
-rw-r--r--kde-base/kcontrol/kcontrol-3.4.1-r1.ebuild44
-rw-r--r--kde-base/kdebase/ChangeLog8
-rw-r--r--kde-base/kdebase/files/digest-kdebase-3.4.1-r11
-rw-r--r--kde-base/kdebase/files/kdebase-3.4.1-configure.patch171
-rw-r--r--kde-base/kdebase/kdebase-3.4.1-r1.ebuild122
8 files changed, 439 insertions, 2 deletions
diff --git a/kde-base/kcontrol/ChangeLog b/kde-base/kcontrol/ChangeLog
index 064d304a2b7e..c7332073dd65 100644
--- a/kde-base/kcontrol/ChangeLog
+++ b/kde-base/kcontrol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kcontrol
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.13 2005/05/27 09:33:26 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.14 2005/06/07 13:01:02 greg_g Exp $
+
+*kcontrol-3.4.1-r1 (07 Jun 2005)
+
+ 07 Jun 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/kdebase-3.4.1-configure.patch, +kcontrol-3.4.1-r1.ebuild:
+ Add patch to properly respect USE flags (#81966, #92433).
27 May 2005; Gregorio Guidi <greg_g@gentoo.org> kcontrol-3.4.1.ebuild:
Add dependency on khelpcenter (#90594).
diff --git a/kde-base/kcontrol/files/digest-kcontrol-3.4.1-r1 b/kde-base/kcontrol/files/digest-kcontrol-3.4.1-r1
new file mode 100644
index 000000000000..518952ccb74d
--- /dev/null
+++ b/kde-base/kcontrol/files/digest-kcontrol-3.4.1-r1
@@ -0,0 +1,3 @@
+MD5 c88659e558ca98dc45377bf8ddfc26c9 kdebase-3.4.0.tar.bz2 22670772
+MD5 3b99262a66edd3c9ad86220ad6cf6579 kdebase-3.4.0-3.4.1.tar.xdelta 1089415
+MD5 8fbe0b943721b79f2549064b580acdde kdebase-3.4.1.tar.bz2 22433034
diff --git a/kde-base/kcontrol/files/kdebase-3.4.1-configure.patch b/kde-base/kcontrol/files/kdebase-3.4.1-configure.patch
new file mode 100644
index 000000000000..319a96702b3d
--- /dev/null
+++ b/kde-base/kcontrol/files/kdebase-3.4.1-configure.patch
@@ -0,0 +1,84 @@
+Index: kcontrol/input/configure.in.bot
+===================================================================
+--- kcontrol/input/configure.in.bot (revision 420060)
++++ kcontrol/input/configure.in.bot (working copy)
+@@ -1,10 +1,4 @@
+-if test "$LUSBLIB" = "no"; then
+- echo
+- echo " Problem! libusb library not found, get it from"
+- echo " http://libusb.sourceforge.net"
+-fi
+-
+-if (test x"$USB_LIBS" = x""); then
++if test "x$with_libusb" = xcheck && test "x$have_libusb" = xno; then
+ echo ""
+ echo "Logitech mouse support is disabled. Provide libusb to enable it."
+ echo ""
+Index: kcontrol/input/configure.in.in
+===================================================================
+--- kcontrol/input/configure.in.in (revision 420060)
++++ kcontrol/input/configure.in.in (working copy)
+@@ -1,19 +1,26 @@
+-LIBUSBCONFIG=""
+-AC_PATH_PROG(LIBUSBCONFIG,libusb-config,no)
+-if test $LIBUSBCONFIG = "no" ; then
+- AC_MSG_WARN(Can't find libusb-config)
+- AC_MSG_WARN(Check your libusb installation)
+- USB_LIBS=""
+- USB_CFLAGS=""
+-else
+- USB_LIBS="$($LIBUSBCONFIG --libs)"
+- USB_CFLAGS="$($LIBUSBCONFIG --cflags)"
+-AC_CHECK_LIB(usb,main,
+- AC_DEFINE(HAVE_LIBUSB, 1, [Defined if you have libusb]),
+- [],
+- $USB_LIBS
+-)
++AC_ARG_WITH(libusb,
++ [AS_HELP_STRING(--with-libusb,
++ [enable control of some mouse models through libusb @<:@default=check@:>@])],
++ [], with_libusb=check)
++
++USB_LIBS=
++USB_CFLAGS=
++have_libusb=no
++if test "x$with_libusb" != xno; then
++ AC_PATH_PROG(LIBUSBCONFIG,libusb-config,no)
++ if test $LIBUSBCONFIG != "no"; then
++ USB_LIBS="$($LIBUSBCONFIG --libs)"
++ USB_CFLAGS="$($LIBUSBCONFIG --cflags)"
++
++ AC_CHECK_LIB(usb,main,
++ [have_libusb=yes
++ AC_DEFINE(HAVE_LIBUSB, 1, [Defined if you have libusb])],
++ [], [$USB_LIBS]
++ )
++ fi
++ if test "x$with_libusb" != xcheck && test "x$have_libusb" = xno; then
++ AC_MSG_FAILURE([--with-libusb was given, but test for libusb failed])
++ fi
+ fi
+ AC_SUBST(USB_LIBS)
+ AC_SUBST(USB_CFLAGS)
+-
+Index: kcontrol/view1394/configure.in.in
+===================================================================
+--- kcontrol/view1394/configure.in.in (revision 420060)
++++ kcontrol/view1394/configure.in.in (working copy)
+@@ -1,3 +1,15 @@
++AC_ARG_WITH(libraw1394,
++ [AS_HELP_STRING(--with-libraw1394,
++ [enable visualization of ieee1394 devices through libraw1394 @<:@default=check@:>@])],
++ [], with_libraw1394=check)
++
+ VIEW1394_SUBDIR=
+-KDE_CHECK_HEADER(libraw1394/raw1394.h, VIEW1394_SUBDIR=view1394)
++if test "x$with_libraw1394" != xno; then
++ KDE_CHECK_HEADER(libraw1394/raw1394.h, VIEW1394_SUBDIR=view1394)
++
++ if test "x$with_libraw1394" != xcheck && test -z "$VIEW1394_SUBDIR"; then
++ AC_MSG_FAILURE([--with-libraw1394 was given, but test for libraw1394 failed])
++ fi
++fi
++
+ AM_CONDITIONAL(include_kcontrol_view1394, test -n "$VIEW1394_SUBDIR")
diff --git a/kde-base/kcontrol/kcontrol-3.4.1-r1.ebuild b/kde-base/kcontrol/kcontrol-3.4.1-r1.ebuild
new file mode 100644
index 000000000000..2748eece6cfe
--- /dev/null
+++ b/kde-base/kcontrol/kcontrol-3.4.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/kcontrol-3.4.1-r1.ebuild,v 1.1 2005/06/07 13:01:02 greg_g Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE Control Center"
+KEYWORDS="~x86 ~amd64 ~ppc64 ~ppc ~sparc"
+IUSE="ssl arts ieee1394 logitech-mouse opengl"
+
+PATCHES="$FILESDIR/configure.in.in-kdm-settings.diff
+ $FILESDIR/kdebase-3.4.1-configure.patch"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
+ opengl? ( virtual/opengl )
+ ieee1394? ( sys-libs/libraw1394 )
+ logitech-mouse? ( >=dev-libs/libusb-0.1.10a )"
+
+RDEPEND="${DEPEND}
+$(deprange $PV $MAXKDEVER kde-base/kcminit)
+$(deprange $PV $MAXKDEVER kde-base/kdebase-data)
+$(deprange $PV $MAXKDEVER kde-base/khelpcenter)"
+
+KMEXTRACTONLY="kicker/core/kicker.h
+ kwin/kwinbindings.cpp
+ kicker/core/kickerbindings.cpp
+ kicker/taskbar/taskbarbindings.cpp
+ kdesktop/kdesktopbindings.cpp
+ klipper/klipperbindings.cpp
+ kxkb/kxkbbindings.cpp
+ libkonq/
+ kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+
+KMCOMPILEONLY="kicker/share" # for kickerSettings.h
+
+src_compile() {
+ myconf="$myconf `use_with ssl` `use_with arts` `use_with opengl gl`
+ `use_with ieee1394 libraw1394` `use_with logitech-mouse libusb`"
+ kde-meta_src_compile
+}
diff --git a/kde-base/kdebase/ChangeLog b/kde-base/kdebase/ChangeLog
index 31e1e77fc0a2..49d67883580d 100644
--- a/kde-base/kdebase/ChangeLog
+++ b/kde-base/kdebase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebase
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.199 2005/05/28 01:26:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.200 2005/06/07 13:00:19 greg_g Exp $
+
+*kdebase-3.4.1-r1 (07 Jun 2005)
+
+ 07 Jun 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/kdebase-3.4.1-configure.patch, +kdebase-3.4.1-r1.ebuild:
+ Add patch to properly respect USE flags (#81966, #92433).
28 May 2005; Diego Pettenò <flameeyes@gentoo.org> kdebase-3.4.1.ebuild:
Moved dependency to virtual/eject.
diff --git a/kde-base/kdebase/files/digest-kdebase-3.4.1-r1 b/kde-base/kdebase/files/digest-kdebase-3.4.1-r1
new file mode 100644
index 000000000000..df3b0dedb416
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-3.4.1-r1
@@ -0,0 +1 @@
+MD5 8fbe0b943721b79f2549064b580acdde kdebase-3.4.1.tar.bz2 22433034
diff --git a/kde-base/kdebase/files/kdebase-3.4.1-configure.patch b/kde-base/kdebase/files/kdebase-3.4.1-configure.patch
new file mode 100644
index 000000000000..e1bed84f7deb
--- /dev/null
+++ b/kde-base/kdebase/files/kdebase-3.4.1-configure.patch
@@ -0,0 +1,171 @@
+diff -Nur kdebase-3.4.1.orig/kcontrol/input/configure.in.bot kdebase-3.4.1/kcontrol/input/configure.in.bot
+--- kdebase-3.4.1.orig/kcontrol/input/configure.in.bot 2005-05-23 14:13:38.000000000 +0200
++++ kdebase-3.4.1/kcontrol/input/configure.in.bot 2005-06-05 22:22:40.000000000 +0200
+@@ -1,10 +1,4 @@
+-if test "$LUSBLIB" = "no"; then
+- echo
+- echo " Problem! libusb library not found, get it from"
+- echo " http://libusb.sourceforge.net"
+-fi
+-
+-if (test x"$USB_LIBS" = x""); then
++if test "x$with_libusb" = xcheck && test "x$have_libusb" = xno; then
+ echo ""
+ echo "Logitech mouse support is disabled. Provide libusb to enable it."
+ echo ""
+diff -Nur kdebase-3.4.1.orig/kcontrol/input/configure.in.in kdebase-3.4.1/kcontrol/input/configure.in.in
+--- kdebase-3.4.1.orig/kcontrol/input/configure.in.in 2005-05-23 14:13:38.000000000 +0200
++++ kdebase-3.4.1/kcontrol/input/configure.in.in 2005-06-05 22:22:40.000000000 +0200
+@@ -1,19 +1,26 @@
+-LIBUSBCONFIG=""
+-AC_PATH_PROG(LIBUSBCONFIG,libusb-config,no)
+-if test $LIBUSBCONFIG = "no" ; then
+- AC_MSG_WARN(Can't find libusb-config)
+- AC_MSG_WARN(Check your libusb installation)
+- USB_LIBS=""
+- USB_CFLAGS=""
+-else
+- USB_LIBS="$($LIBUSBCONFIG --libs)"
+- USB_CFLAGS="$($LIBUSBCONFIG --cflags)"
+-AC_CHECK_LIB(usb,main,
+- AC_DEFINE(HAVE_LIBUSB, 1, [Defined if you have libusb]),
+- [],
+- $USB_LIBS
+-)
++AC_ARG_WITH(libusb,
++ [AS_HELP_STRING(--with-libusb,
++ [enable control of some mouse models through libusb @<:@default=check@:>@])],
++ [], with_libusb=check)
++
++USB_LIBS=
++USB_CFLAGS=
++have_libusb=no
++if test "x$with_libusb" != xno; then
++ AC_PATH_PROG(LIBUSBCONFIG,libusb-config,no)
++ if test $LIBUSBCONFIG != "no"; then
++ USB_LIBS="$($LIBUSBCONFIG --libs)"
++ USB_CFLAGS="$($LIBUSBCONFIG --cflags)"
++
++ AC_CHECK_LIB(usb,main,
++ [have_libusb=yes
++ AC_DEFINE(HAVE_LIBUSB, 1, [Defined if you have libusb])],
++ [], [$USB_LIBS]
++ )
++ fi
++ if test "x$with_libusb" != xcheck && test "x$have_libusb" = xno; then
++ AC_MSG_FAILURE([--with-libusb was given, but test for libusb failed])
++ fi
+ fi
+ AC_SUBST(USB_LIBS)
+ AC_SUBST(USB_CFLAGS)
+-
+diff -Nur kdebase-3.4.1.orig/kcontrol/view1394/configure.in.in kdebase-3.4.1/kcontrol/view1394/configure.in.in
+--- kdebase-3.4.1.orig/kcontrol/view1394/configure.in.in 2005-05-23 14:13:48.000000000 +0200
++++ kdebase-3.4.1/kcontrol/view1394/configure.in.in 2005-06-05 22:22:48.000000000 +0200
+@@ -1,3 +1,15 @@
++AC_ARG_WITH(libraw1394,
++ [AS_HELP_STRING(--with-libraw1394,
++ [enable visualization of ieee1394 devices through libraw1394 @<:@default=check@:>@])],
++ [], with_libraw1394=check)
++
+ VIEW1394_SUBDIR=
+-KDE_CHECK_HEADER(libraw1394/raw1394.h, VIEW1394_SUBDIR=view1394)
++if test "x$with_libraw1394" != xno; then
++ KDE_CHECK_HEADER(libraw1394/raw1394.h, VIEW1394_SUBDIR=view1394)
++
++ if test "x$with_libraw1394" != xcheck && test -z "$VIEW1394_SUBDIR"; then
++ AC_MSG_FAILURE([--with-libraw1394 was given, but test for libraw1394 failed])
++ fi
++fi
++
+ AM_CONDITIONAL(include_kcontrol_view1394, test -n "$VIEW1394_SUBDIR")
+diff -Nur kdebase-3.4.1.orig/kioslave/smb/configure.in.bot kdebase-3.4.1/kioslave/smb/configure.in.bot
+--- kdebase-3.4.1.orig/kioslave/smb/configure.in.bot 2005-05-23 14:14:19.000000000 +0200
++++ kdebase-3.4.1/kioslave/smb/configure.in.bot 2005-06-05 22:22:43.000000000 +0200
+@@ -1,4 +1,4 @@
+-if test "$have_libsmbclient" = no; then
++if test "x$with_samba" = xcheck && test "x$have_libsmbclient" = xno; then
+ echo ""
+ echo "You're missing libsmbclient from samba 3.0"
+ echo "KDE will not be able to browse windows shares without it,"
+diff -Nur kdebase-3.4.1.orig/kioslave/smb/configure.in.in kdebase-3.4.1/kioslave/smb/configure.in.in
+--- kdebase-3.4.1.orig/kioslave/smb/configure.in.in 2005-05-23 14:14:19.000000000 +0200
++++ kdebase-3.4.1/kioslave/smb/configure.in.in 2005-06-05 22:22:43.000000000 +0200
+@@ -1,20 +1,34 @@
+ AC_DEFUN([SMB_CHECK],
+ [
+ AC_REQUIRE([KDE_CHECK_LARGEFILE])
+-have_libsmbclient=yes
+-KDE_CHECK_HEADER(libsmbclient.h, ,[have_libsmbclient=no] )
+-KDE_CHECK_LIB(smbclient, smbc_new_context, [] ,[have_libsmbclient=no])
+
+-AM_CONDITIONAL(include_kioslave_smb, test "$have_libsmbclient" = yes)
++AC_ARG_WITH(samba,
++ [AS_HELP_STRING(--with-samba,
++ [enable the samba ioslave @<:@default=check@:>@])],
++ [], with_samba=check)
+
+-SMBCLIENT_EXTRA_LIBS=""
+-AC_CHECK_FUNC(yp_get_default_domain, [],
++have_libsmbclient=no
++if test "x$with_samba" != xno; then
++ have_libsmbclient=yes
++ KDE_CHECK_HEADER(libsmbclient.h, [], [have_libsmbclient=no])
++ KDE_CHECK_LIB(smbclient, smbc_new_context, [], [have_libsmbclient=no])
++
++ SMBCLIENT_EXTRA_LIBS=""
++ AC_CHECK_FUNC(yp_get_default_domain, [],
+ [
+ KDE_CHECK_LIB(nsl, yp_get_default_domain,
+ [SMBCLIENT_EXTRA_LIBS="-lnsl"] )
+ ])
+
+-AC_SUBST(SMBCLIENT_EXTRA_LIBS)
++ AC_SUBST(SMBCLIENT_EXTRA_LIBS)
++
++ if test "x$with_samba" != xcheck && test "x$have_libsmbclient" = xno; then
++ AC_MSG_FAILURE([--with-samba was given, but test for libsmbclient failed])
++ fi
++fi
++
++AM_CONDITIONAL(include_kioslave_smb, test "x$have_libsmbclient" = xyes)
++
+ ])
+
+ SMB_CHECK
+diff -Nur kdebase-3.4.1.orig/ksysguard/configure.in.in kdebase-3.4.1/ksysguard/configure.in.in
+--- kdebase-3.4.1.orig/ksysguard/configure.in.in 2005-05-23 14:15:09.000000000 +0200
++++ kdebase-3.4.1/ksysguard/configure.in.in 2005-06-05 22:22:46.000000000 +0200
+@@ -23,11 +23,19 @@
+ AM_CONDITIONAL(include_ksysguardd_openbsd, test "$UNAME" = OpenBSD)
+ AC_SUBST(UNAME)
+
+-KDE_CHECK_LIB(sensors, sensors_init, [LIBSENSORS="-lsensors"])
+-AC_SUBST(LIBSENSORS)
++AC_ARG_WITH(sensors,
++ [AS_HELP_STRING(--with-sensors,
++ [enable support for lm_sensors @<:@default=check@:>@])],
++ [], with_sensors=check)
+
+-dnl Check for dell laptop support
+-AM_CONDITIONAL(supports_i8k, test -f /proc/i8k)
++if test "x$with_sensors" != xno; then
++ KDE_CHECK_HEADERS(sensors/sensors.h)
++ KDE_CHECK_LIB(sensors, sensors_init, [LIBSENSORS="-lsensors"])
++
++ if test "x$with_readline" != xcheck && test -z "$LIBSENSORS"; then
++ AC_MSG_FAILURE([--with-sensors was given, but test for lm_sensors failed])
++ fi
++fi
+
+ case "$UNAME" in
+ Linux) LIBHOSTS="$LIBSENSORS" ;;
+@@ -35,5 +43,7 @@
+ Solaris) LIBHOSTS="$LIBSENSORS -lkstat -lsocket" ;;
+ esac
+ AC_SUBST(LIBHOSTS)
++AC_SUBST(LIBSENSORS)
+
+-KDE_CHECK_HEADERS(sensors/sensors.h)
++dnl Check for dell laptop support
++AM_CONDITIONAL(supports_i8k, test -f /proc/i8k)
diff --git a/kde-base/kdebase/kdebase-3.4.1-r1.ebuild b/kde-base/kdebase/kdebase-3.4.1-r1.ebuild
new file mode 100644
index 000000000000..46505f91ad57
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.4.1-r1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.4.1-r1.ebuild,v 1.1 2005/06/07 13:00:19 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE base packages: the desktop, panel, window manager, konqueror..."
+
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~ia64"
+IUSE="arts cups java ldap ieee1394 hal lm_sensors logitech-mouse opengl pam samba ssl"
+# hal: enables hal backend for 'media:' ioslave
+
+DEPEND="arts? ( ~kde-base/arts-${PV} )
+ pam? ( kde-base/kdebase-pam )
+ >=dev-libs/cyrus-sasl-2
+ ldap? ( >=net-nds/openldap-2 )
+ cups? ( net-print/cups )
+ ssl? ( dev-libs/openssl )
+ opengl? ( virtual/opengl )
+ samba? ( >=net-fs/samba-3.0.4 )
+ lm_sensors? ( sys-apps/lm_sensors )
+ logitech-mouse? ( >=dev-libs/libusb-0.1.10a )
+ ieee1394? ( sys-libs/libraw1394 )
+ hal? ( =sys-apps/dbus-0.23*
+ =sys-apps/hal-0.4* )"
+
+RDEPEND="${DEPEND}
+ java? ( || ( virtual/jdk virtual/jre ) )
+ virtual/eject"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ kde_src_unpack
+
+ epatch "${FILESDIR}/${P}-configure.patch"
+ epatch "${FILESDIR}/${P}-startkde-gentoo.patch"
+
+ # for the configure patch
+ make -f admin/Makefile.common || die
+}
+
+src_compile() {
+ myconf="--with-dpms
+ $(use_with arts) $(use_with ldap)
+ $(use_with cups) $(use_with opengl gl)
+ $(use_with ssl) $(use_with samba)
+ $(use_with lm_sensors sensors) $(use_with logitech-mouse libusb)
+ $(use_with ieee1394 libraw1394) $(use_with hal)"
+
+ use pam && myconf="${myconf} --with-pam=yes" \
+ || myconf="${myconf} --with-pam=no --with-shadow"
+
+ # the java test is problematic (see kde bug 100729) and
+ # useless. All that's needed for java applets to work is
+ # to have the 'java' executable in PATH.
+ myconf="${myconf} --without-java"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+ cd ${S}/kdm && make DESTDIR=${D} GENKDMCONF_FLAGS="--no-old --no-backup --no-in-notice" install
+
+ # startup and shutdown scripts
+ insinto ${KDEDIR}/env
+ doins ${FILESDIR}/agent-startup.sh
+
+ exeinto ${KDEDIR}/shutdown
+ doexe ${FILESDIR}/agent-shutdown.sh
+
+ # freedesktop environment variables
+ cat <<EOF > ${T}/xdg.sh
+export XDG_DATA_DIRS="${KDEDIR}/share:/usr/share"
+export XDG_CONFIG_DIRS="${KDEDIR}/etc/xdg"
+EOF
+ insinto ${KDEDIR}/env
+ doins ${T}/xdg.sh
+
+ # x11 session script
+ cat <<EOF > ${T}/kde-${SLOT}
+#!/bin/sh
+exec ${KDEDIR}/bin/startkde
+EOF
+ exeinto /etc/X11/Sessions
+ doexe ${T}/kde-${SLOT}
+
+ # freedesktop compliant session script
+ sed -e "s:@KDE_BINDIR@:${KDEDIR}/bin:g;s:Name=KDE:Name=KDE ${SLOT}:" \
+ ${S}/kdm/kfrontend/sessions/kde.desktop.in > ${T}/kde-${SLOT}.desktop
+ insinto /usr/share/xsessions
+ doins ${T}/kde-${SLOT}.desktop
+
+ # Customize the kdmrc configuration
+ sed -i -e "s:#SessionsDirs=:SessionsDirs=/usr/share/xsessions\n#SessionsDirs=:" \
+ -e "s:#GreetFont=:GreetFont=Sans Serif,24,-1,5,50,0,0,0,0,0\n#GreetFont=:" \
+ -e "s:#StdFont=:StdFont=Sans Serif,12,-1,5,50,0,0,0,0,0\n#StdFont=:" \
+ -e "s:#FailFont=:FailFont=Sans Serif,12,-1,5,75,0,0,0,0,0\n#FailFont=:" \
+ -e "s:#AntiAliasing=:AntiAliasing=true\n#AntiAliasing=:" \
+ ${D}/${KDEDIR}/share/config/kdm/kdmrc || die
+
+ rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
+}
+
+pkg_postinst() {
+ # set the default kdm face icon if it's not already set by the system admin
+ if [ ! -e "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon" ]; then
+ mkdir -p "${ROOT}${KDEDIR}/share/apps/kdm/faces"
+ cp "${ROOT}${KDEDIR}/share/apps/kdm/pics/users/default1.png" \
+ "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon"
+ fi
+
+ mkdir -p ${ROOT}${KDEDIR}/share/templates/.source/emptydir
+
+ echo
+ einfo "To enable gpg-agent and/or ssh-agent in KDE sessions,"
+ einfo "edit ${KDEDIR}/env/agent-startup.sh and"
+ einfo "${KDEDIR}/shutdown/agent-shutdown.sh"
+ echo
+}