summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/alsa-lib/alsa-lib-0.9.0_rc5.ebuild')
-rw-r--r--media-libs/alsa-lib/alsa-lib-0.9.0_rc5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/alsa-lib-0.9.0_rc5.ebuild b/media-libs/alsa-lib/alsa-lib-0.9.0_rc5.ebuild
new file mode 100644
index 000000000000..f832de7e2b0e
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-0.9.0_rc5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-0.9.0_rc5.ebuild,v 1.1 2002/10/24 20:50:22 agenkin Exp $
+
+MY_P=${P/_rc/rc}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="ftp://ftp.alsa-project.org/pub/lib/${MY_P}.tar.bz2"
+
+DEPEND="virtual/glibc
+ ~media-sound/alsa-driver-0.9.0_rc5"
+
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64"
+LICENSE="GPL-2 LGPL-2.1"
+
+src_compile() {
+
+ econf || die "./configure failed"
+
+ make || die "make failed"
+}
+
+src_install() {
+
+ einstall || die "Installation Failed"
+
+ #This alsa version does not provide libasound.so.1
+ #Without this library just about everything even remotely
+ #linked to previous versions of alsa-lib will break.
+ #Fortunately, libasound.so.2 seems to be backwards
+ #compatible with libasound.so.2 and a simple link
+ #fixes the problem (fingers crossed)
+ dosym /usr/lib/libasound.so.2 /usr/lib/libasound.so.1
+
+ dodoc ChangeLog COPYING TODO
+}