summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libvorbis/libvorbis-1.0-r1.ebuild')
-rw-r--r--media-libs/libvorbis/libvorbis-1.0-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/libvorbis/libvorbis-1.0-r1.ebuild b/media-libs/libvorbis/libvorbis-1.0-r1.ebuild
new file mode 100644
index 000000000000..2bda2349b372
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.0-r1.ebuild,v 1.1 2002/09/13 17:46:57 lostlogic Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="the Ogg Vorbis sound file format library"
+SRC_URI="http://fatpipe.vorbis.com/files/1.0/unix/${P}.tar.gz"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+
+DEPEND=">=media-libs/libogg-1.0"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ppc sparc sparc64"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-m4.patch || die "Patching failed"
+ # Fix a gcc crash. With the new atexit patch to gcc, it
+ # seems it do not handle -mno-ieee-fp too well.
+ cp configure configure.orig
+ sed -e "s:-mno-ieee-fp::g" \
+ configure.orig >configure
+}
+
+src_compile() {
+ elibtoolize
+
+ export CFLAGS="${CFLAGS/-march=*/}"
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ echo "Removing docs installed by make install"
+ rm -rf ${D}/usr/share/doc
+
+ dodoc AUTHORS COPYING README todo.txt
+ docinto txt
+ dodoc doc/*.txt
+ dohtml -r doc
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Note the 1.0 version of libvorbis has been installed"
+ einfo "Applications that used pre-1.0 vorbis libraries will"
+ einfo "need to be recompiled for the new version."
+ einfo "Now that the vorbis folks have finalized the API"
+ einfo "this should be the last time for a while that"
+ einfo "recompilation is needed for these things."
+ einfo
+}