summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libvorbis/libvorbis-1.0_rc3-r2.ebuild')
-rw-r--r--media-libs/libvorbis/libvorbis-1.0_rc3-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/libvorbis/libvorbis-1.0_rc3-r2.ebuild b/media-libs/libvorbis/libvorbis-1.0_rc3-r2.ebuild
new file mode 100644
index 000000000000..107f855c884c
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.0_rc3-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.0_rc3-r2.ebuild,v 1.1 2002/06/30 13:23:04 azarah Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${PN}-1.0rc3
+DESCRIPTION="the Ogg Vorbis sound file format library"
+SRC_URI="http://www.vorbis.com/files/rc3/unix/${PN}-1.0rc3.tar.gz"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+
+DEPEND=">=media-libs/libogg-1.0_rc2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fix a gcc crash. With the new atexit patch to gcc, it
+ # seems it do not handle -mno-ieee-fp too well.
+ cp configure configure.orig
+ sed -e "s:-mno-ieee-fp::g" \
+ configure.orig >configure
+}
+
+src_compile() {
+ elibtoolize
+
+ export CFLAGS="${CFLAGS/-march=*/}"
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ echo "Removing docs installed by make install"
+ rm -rf ${D}/usr/share/doc
+
+ dodoc AUTHORS COPYING README todo.txt
+ docinto txt
+ dodoc doc/*.txt
+ dohtml -r doc
+}