summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/x264/x264-0.0.20090908.ebuild')
-rw-r--r--media-libs/x264/x264-0.0.20090908.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/media-libs/x264/x264-0.0.20090908.ebuild b/media-libs/x264/x264-0.0.20090908.ebuild
deleted file mode 100644
index b5162e64b7c4..000000000000
--- a/media-libs/x264/x264-0.0.20090908.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20090908.ebuild,v 1.1 2009/09/09 08:57:19 ssuominen Exp $
-
-EAPI=2
-inherit eutils multilib toolchain-funcs versionator
-
-MY_P=x264-snapshot-$(get_version_component_range 3)-2245
-
-DESCRIPTION="A free library for encoding X264/AVC streams"
-HOMEPAGE="http://www.videolan.org/developers/x264.html"
-SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug +threads"
-# pic
-
-RDEPEND=""
-DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
- x86? ( >=dev-lang/yasm-0.6.2 )
- x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-nostrip.patch \
- "${FILESDIR}"/${PN}-onlylib-20090408.patch
-}
-
-src_configure() {
- tc-export CC
-
- local myconf=""
- use debug && myconf="${myconf} --enable-debug"
-
-# if use x86 && use pic; then
-# myconf="${myconf} --disable-asm"
-# fi
-
- ./configure \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- --disable-avis-input \
- --disable-mp4-output \
- $(use_enable threads pthread) \
- --enable-pic \
- --enable-shared \
- --extra-asflags="${ASFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- --extra-ldflags="${LDFLAGS}" \
- --host="${CHOST}" \
- ${myconf} \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS doc/*.txt
-}