summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/efxmms/efxmms-0.0.3.ebuild')
-rw-r--r--media-plugins/efxmms/efxmms-0.0.3.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/media-plugins/efxmms/efxmms-0.0.3.ebuild b/media-plugins/efxmms/efxmms-0.0.3.ebuild
index dc758e8b55b4..44d5fd3e6982 100644
--- a/media-plugins/efxmms/efxmms-0.0.3.ebuild
+++ b/media-plugins/efxmms/efxmms-0.0.3.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/efxmms/efxmms-0.0.3.ebuild,v 1.5 2004/04/20 17:42:37 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/efxmms/efxmms-0.0.3.ebuild,v 1.6 2004/06/18 05:51:14 eradicator Exp $
IUSE=""
+inherit gnuconfig
+
MY_P=${PN/efx/EFX}-${PV}
S=${WORKDIR}/${MY_P}
DESCRIPTION="Provides the possibility to send the audio through a queue of multiple effect plugins instead of one effect that XMMS originally handles"
@@ -12,10 +14,16 @@ SRC_URI="mirror://sourceforge/efxmms/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~amd64"
DEPEND="media-sound/xmms"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use amd64 && gnuconfig_update
+}
+
src_install() {
einstall \
libdir=${D}/usr/lib/xmms/Effect || die