summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-graphtft/files')
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_gcc-4.4.x.diff22
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_gentoo.diff139
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_makefile.diff67
3 files changed, 228 insertions, 0 deletions
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_gcc-4.4.x.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_gcc-4.4.x.diff
new file mode 100644
index 000000000000..4e32c187ac10
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_gcc-4.4.x.diff
@@ -0,0 +1,22 @@
+diff -Naur graphtft-30.orig/graphtft-fe/common.cc graphtft-30/graphtft-fe/common.cc
+--- graphtft-30.orig/graphtft-fe/common.cc 2012-03-12 02:10:38.000000000 +0100
++++ graphtft-30/graphtft-fe/common.cc 2012-03-12 02:30:16.000000000 +0100
+@@ -11,6 +11,7 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <stdint.h>
+
+ #include <graphtft.hpp>
+
+diff -Naur graphtft-30.orig/graphtft-fe/graphtft.hpp graphtft-30/graphtft-fe/graphtft.hpp
+--- graphtft-30.orig/graphtft-fe/graphtft.hpp 2012-03-12 02:10:38.000000000 +0100
++++ graphtft-30/graphtft-fe/graphtft.hpp 2012-03-12 02:30:57.000000000 +0100
+@@ -16,6 +16,7 @@
+ #include <X11/Xlib.h>
+ #include <Imlib2.h>
+ #include <string.h>
++#include <stdint.h>
+
+ #define __FRONTEND
+ #include <../common.h>
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_gentoo.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_gentoo.diff
new file mode 100644
index 000000000000..ea0e7ad3d748
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_gentoo.diff
@@ -0,0 +1,139 @@
+diff -Naur graphtft-30.orig/dfbrenderer/dfbrenderer.c graphtft-30/dfbrenderer/dfbrenderer.c
+--- graphtft-30.orig/dfbrenderer/dfbrenderer.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/dfbrenderer/dfbrenderer.c 2012-03-12 03:29:35.000000000 +0100
+@@ -257,7 +257,7 @@
+ {
+ // make path relative to the themes directory
+
+- asprintf(&path, "%s/graphTFT/themes/%s/%s",
++ asprintf(&path, "%s/themes/%s/%s",
+ confPath.c_str(), themePath.c_str(), p.c_str());
+ }
+ else
+@@ -281,7 +281,7 @@
+
+ // at least add the default path
+
+- asprintf(&path, "%s/graphTFT/fonts/", confPath.c_str());
++ asprintf(&path, "%s/fonts/", confPath.c_str());
+ tell(0, "Info: Adding font path '%s'", path);
+ fontPaths[count] = path;
+ free(path);
+@@ -483,7 +483,7 @@
+ else
+ {
+ const char* tmp = themePath.c_str();
+- asprintf(&fpath, "%s/graphTFT/themes/%s/%s", confPath.c_str(), tmp, fname);
++ asprintf(&fpath, "%s/themes/%s/%s", confPath.c_str(), tmp, fname);
+ }
+
+ tell(4,"creating imageprovider for %s", fpath);
+@@ -561,7 +561,7 @@
+ else
+ {
+ const char* tmp = themePath.c_str();
+- asprintf(&fpath, "%s/graphTFT/themes/%s/%s", confPath.c_str(), tmp, fname);
++ asprintf(&fpath, "%s/themes/%s/%s", confPath.c_str(), tmp, fname);
+ }
+
+ tell(4,"creating imageprovider for %s", fpath);
+diff -Naur graphtft-30.orig/dspitems.c graphtft-30/dspitems.c
+--- graphtft-30.orig/dspitems.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/dspitems.c 2012-03-12 03:30:16.000000000 +0100
+@@ -107,7 +107,7 @@
+ if (p[0] != '/')
+ {
+ p = string(GraphTFTSetup.PluginConfPath)
+- + "/graphTFT/themes/"
++ + "/themes/"
+ + string(Thms::theTheme->getDir())
+ + "/" + p;
+ }
+diff -Naur graphtft-30.orig/graphtft.c graphtft-30/graphtft.c
+--- graphtft-30.orig/graphtft.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/graphtft.c 2012-03-12 03:32:48.000000000 +0100
+@@ -22,6 +22,8 @@
+ #include <graphtft.h>
+ #include <span.h>
+
++#define DATA_DIR "/usr/share/vdr/graphTFT"
++
+ //***************************************************************************
+ // cGraphTFTMenu
+ //***************************************************************************
+@@ -300,13 +302,13 @@
+
+ // try to get the config dir
+
+- if (!ConfigDirectory())
+- return false;
++// if (!ConfigDirectory())
++// return false;
+
+ // init
+
+ GraphTFTSetup.setClient(this);
+- GraphTFTSetup.PluginConfPath = strdup(ConfigDirectory());
++ GraphTFTSetup.PluginConfPath = strdup(DATA_DIR);
+
+ #if APIVERSNUM < 10507
+ RegisterI18n(Phrases);
+@@ -322,7 +324,7 @@
+ if (loadThemes() != 0)
+ return false;
+
+- if (display->Init(_dev, ConfigDirectory(), port) != success)
++ if (display->Init(_dev, DATA_DIR, port) != success)
+ {
+ tell(0, "Error: Initializing graphTFT device faild, aborting!");
+
+@@ -355,8 +357,8 @@
+
+ // look for the themes in the config directory
+
+- asprintf(&buffer, "find %s/graphTFT/themes -follow -type f -name '*.theme' | sort",
+- ConfigDirectory());
++ asprintf(&buffer, "find %s/themes -follow -type f -name '*.theme' | sort",
++ DATA_DIR);
+
+ p = popen(buffer, "r");
+
+diff -Naur graphtft-30.orig/imlibrenderer/imlibrenderer.c graphtft-30/imlibrenderer/imlibrenderer.c
+--- graphtft-30.orig/imlibrenderer/imlibrenderer.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/imlibrenderer/imlibrenderer.c 2012-03-12 03:33:54.000000000 +0100
+@@ -123,7 +123,7 @@
+ {
+ // make path relative to the themes directory
+
+- asprintf(&path, "%s/graphTFT/themes/%s/%s",
++ asprintf(&path, "%s/themes/%s/%s",
+ confPath.c_str(), themePath.c_str(), p.c_str());
+ }
+ else
+@@ -146,7 +146,7 @@
+
+ // at least add the default path
+
+- asprintf(&path, "%s/graphTFT/fonts/", confPath.c_str());
++ asprintf(&path, "%s/fonts/", confPath.c_str());
+ tell(0, "Info: Adding font path '%s'", path);
+ imlib_add_path_to_font_path(path);
+ free(path);
+@@ -217,7 +217,7 @@
+ if (fname[0] == '/')
+ path << fname;
+ else
+- path << confPath << "/graphTFT/themes/" << themePath << "/" << fname;
++ path << confPath << "/themes/" << themePath << "/" << fname;
+
+ if (!fileExists(path.str().c_str()))
+ {
+@@ -291,7 +291,7 @@
+ if (fname[0] == '/')
+ path << fname;
+ else
+- path << confPath << "/graphTFT/themes/" << themePath << "/" << fname;
++ path << confPath << "/themes/" << themePath << "/" << fname;
+
+ if (!fileExists(path.str().c_str()))
+ {
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_makefile.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_makefile.diff
new file mode 100644
index 000000000000..f638be630069
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.6_makefile.diff
@@ -0,0 +1,67 @@
+Joerg Bornkessel <hd_brummy@g.o> 22 Okt 2009
+Matthias Schwarzott <zzam@g.o> 23 Okt 2009
+diff -Naur graphtft-24.orig/Makefile graphtft-24/Makefile
+--- graphtft-24.orig/Makefile 2009-10-21 21:53:56.000000000 +0200
++++ graphtft-24/Makefile 2009-10-21 21:57:24.000000000 +0200
+@@ -158,10 +158,10 @@
+ DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+ ifdef HAVE_IMLIB
+- LIBS += `imlib2-config --libs`
++ LIBS += $(shell imlib2-config --libs)
+
+ ifdef HAVE_IMAGE_MAGICK
+- LIBS += `Magick++-config --libs`
++ LIBS += $(shell Magick++-config --libs)
+ DEFINES += -DHAVE_IMAGE_MAGICK
+ endif
+
+@@ -170,8 +170,8 @@
+ endif
+
+ ifdef HAVE_GTOP
+- GTOP_INC = `pkg-config libgtop-2.0 --cflags`
+- GTOP_LIB = `pkg-config libgtop-2.0 --libs`
++ GTOP_INC = $(shell pkg-config libgtop-2.0 --cflags)
++ GTOP_LIB = $(shell pkg-config libgtop-2.0 --libs)
+
+ DEFINES += -DWITH_SYSINFO
+ LIBS += $(GTOP_LIB)
+@@ -186,8 +186,8 @@
+ endif
+
+ ifdef HAVE_DFB
+- INCLUDES += `directfb-config --cflags`
+- LIBS += `directfb-config --libs`
++ INCLUDES += $(shell directfb-config --cflags)
++ LIBS += $(shell directfb-config --libs)
+ DEFINES += -DHAVE_DFB
+ endif
+
+diff -Naur graphtft-24.orig/graphtft-fe/Makefile graphtft-24/graphtft-fe/Makefile
+--- graphtft-24.orig/graphtft-fe/Makefile 2009-10-22 17:39:55.000000000 +0200
++++ graphtft-24/graphtft-fe/Makefile 2009-10-22 17:41:29.000000000 +0200
+@@ -1,9 +1,9 @@
+
+ CXX = g++
+ CXXFLAGS = -pipe -ggdb -O2 -Wall -W -D_REENTRANT -fPIC
+-INCPATH = -I. `Magick++-config --cppflags`
++INCPATH = -I. $(shell Magick++-config --cppflags)
+ LFLAGS = -Wl,--no-undefined
+-LIBS = -lpthread `imlib2-config --libs` `Magick++-config --libs`
++LIBS = -lpthread $(shell imlib2-config --libs) $(shell Magick++-config --libs)
+ AR = ar
+
+ TARGET = graphtft-fe
+diff -Naur graphtft-24.orig/graphtft-fe/Makefile graphtft-24/graphtft-fe/Makefile
+--- graphtft-24.orig/graphtft-fe/Makefile 2009-10-23 16:20:43.000000000 +0200
++++ graphtft-24/graphtft-fe/Makefile 2009-10-23 16:21:20.000000000 +0200
+@@ -17,7 +17,7 @@
+
+ all:
+ echo Build graphTFT Frontend
+- @(make $(TARGET))
++ @$(MAKE) $(TARGET)
+
+
+ $(TARGET): $(OBJECTS)