summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/xmms-wma/xmms-wma-1.0.5.ebuild')
-rw-r--r--media-plugins/xmms-wma/xmms-wma-1.0.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/xmms-wma/xmms-wma-1.0.5.ebuild b/media-plugins/xmms-wma/xmms-wma-1.0.5.ebuild
new file mode 100644
index 000000000000..b809fbb02734
--- /dev/null
+++ b/media-plugins/xmms-wma/xmms-wma-1.0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-wma/xmms-wma-1.0.5.ebuild,v 1.1 2005/10/24 00:46:58 metalgod Exp $
+
+IUSE=""
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="XMMS plugin to play wma"
+HOMEPAGE="http://mcmcc.bat.ru/xmms-wma/"
+SRC_URI="http://mcmcc.bat.ru/xmms-wma/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+#~sparc: 1.0.4: Plays a little staticy, x86/adm64 is clear...
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="media-sound/xmms
+ >=media-video/ffmpeg-0.4.9_p20050226-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-ffmpeg.patch
+}
+
+src_compile () {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install () {
+ exeinto `xmms-config --input-plugin-dir`
+ doexe libwma.so
+ dodoc readme.rus readme.eng
+}