summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/aumix/aumix-2.8-r1.ebuild')
-rw-r--r--media-sound/aumix/aumix-2.8-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/aumix/aumix-2.8-r1.ebuild b/media-sound/aumix/aumix-2.8-r1.ebuild
new file mode 100644
index 000000000000..a2fe0e10913a
--- /dev/null
+++ b/media-sound/aumix/aumix-2.8-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/aumix-2.8-r1.ebuild,v 1.1 2004/04/18 08:44:14 eradicator Exp $
+
+IUSE="gtk gtk2 gnome gpm nls"
+
+DESCRIPTION="Aumix volume/mixer control program."
+SRC_URI="http://jpj.net/~trevor/aumix/${P}.tar.bz2"
+HOMEPAGE="http://jpj.net/~trevor/aumix/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~hppa ~amd64 ~sparc ~alpha ~ia64"
+
+#alsa support is broken in 2.8 alsa? ( >=media-libs/alsa-lib-0.9.0_rc1 )
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ gtk? (
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( >=x11-libs/gtk+-2.0.0 )
+ )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+# `use_with alsa`
+
+ # use_with borks becasue of bad configure script.
+ if use gtk; then
+ if use gtk2; then
+ myconf="${myconf} --without-gtk1";
+ else
+ myconf="${myconf} --without-gtk";
+ fi
+ else
+ myconf="${myconf} --without-gtk --without-gtk1";
+ fi
+
+ if ! use gpm; then
+ myconf="${myconf} --without-gpm"
+ fi
+
+ econf ${myconf} || die
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall
+
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README TODO
+
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/aumix.desktop
+ insinto /usr/share/applnk/Multimedia
+ doins ${FILESDIR}/aumix.desktop
+ insinto /usr/share/applications
+ doins ${FILESDIR}/aumix.desktop
+
+ dodir /usr/share/pixmaps
+ ln -s ../aumix/aumix.xpm ${D}/usr/share/pixmaps
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/aumix.rc6 aumix
+}