summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/vorbis-tools/vorbis-tools-1.1.1-r2.ebuild')
-rw-r--r--media-sound/vorbis-tools/vorbis-tools-1.1.1-r2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-sound/vorbis-tools/vorbis-tools-1.1.1-r2.ebuild b/media-sound/vorbis-tools/vorbis-tools-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..4dee3703edad
--- /dev/null
+++ b/media-sound/vorbis-tools/vorbis-tools-1.1.1-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbis-tools/vorbis-tools-1.1.1-r2.ebuild,v 1.1 2006/03/08 22:13:02 nattfodd Exp $
+
+IUSE="nls flac speex"
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="tools for using the Ogg Vorbis sound file format"
+HOMEPAGE="http://www.vorbis.com/"
+SRC_URI="http://downloads.xiph.org/releases/vorbis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=media-libs/libvorbis-1.1.0
+ >=media-libs/libao-0.8.2
+ >=net-misc/curl-7.9
+ speex? ( media-libs/speex )
+ flac? ( media-libs/flac )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ if use flac && ! built_with_use media-libs/flac ogg; then
+ eerror "To be able to play OggFlac files you need to build"
+ eerror "media-libs/flac with +ogg, to build libOggFLAC."
+ die "Missing libOggFLAC library."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-utf8.patch
+}
+
+src_compile() {
+ use hppa && [ "`gcc-fullversion`" == "3.3.2" ] && replace-flags -march=2.0 -march=1.0
+ local myconf
+
+ # --with-flac is not supported. See bug #49763
+ use flac || myconf="${myconf} --without-flac"
+ # --with-speex is not supported. See bug #97316
+ use speex || myconf="${myconf} --without-speex"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ rm -rf ${D}/usr/share/doc
+ dodoc AUTHORS README
+ docinto ogg123
+ dodoc ogg123/ogg123rc-example
+}