summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/clive/clive-0.4.17.ebuild')
-rw-r--r--media-video/clive/clive-0.4.17.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-video/clive/clive-0.4.17.ebuild b/media-video/clive/clive-0.4.17.ebuild
new file mode 100644
index 000000000000..baf6fea8761c
--- /dev/null
+++ b/media-video/clive/clive-0.4.17.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-0.4.17.ebuild,v 1.1 2008/07/01 05:46:44 aballier Exp $
+
+# We inherit distutils to get the pkg_* functions for byte compiling python
+inherit versionator distutils
+
+DESCRIPTION="Command line tool for extracting videos from Youtube, Google Video, Dailymotion, Guba (free) and Stage6 websites"
+HOMEPAGE="http://home.gna.org/clive/"
+SRC_URI="http://dl.gna.org/clive/$(get_version_component_range 1-2 ${PV})/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=dev-libs/newt-0.51
+ >=dev-python/urlgrabber-3.1.0
+ >=dev-python/feedparser-4.1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ # with-lib means compile its own
+ econf $(use_with doc) \
+ --without-newt \
+ --without-feedparser \
+ --without-urlgrabber
+ emake || die "emake failed"
+ if use doc; then
+ emake dox || die "failed to create the documentation"
+ fi
+}
+
+src_install() {
+ emake py_compile=true DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog README
+ use doc && dohtml dox/html/*
+}