summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild b/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild
index 0856560e0f62..bf5f9b58d97b 100644
--- a/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild
+++ b/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild,v 1.13 2006/04/20 21:57:34 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild,v 1.14 2006/05/08 04:23:11 flameeyes Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -178,6 +178,11 @@ src_compile() {
fi
fi
+ # This is needed to make sure that when linking with --as-needed all the
+ # libraries are found in the right places, not suitable for upstream yet as
+ # it's GNU-ld only (most likely).
+ append-ldflags "-Wl,-rpath-link,${S_SHARED}/libav"{codec,format,util}
+
cd ${S_SHARED}
#econf generates configure options unknown to ffmpeg's configure, so configure manually
./configure \