summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/miro')
-rw-r--r--media-video/miro/ChangeLog9
-rw-r--r--media-video/miro/files/miro-2.5.3-remove-pkg-config-list-all.patch74
-rw-r--r--media-video/miro/miro-2.5.3.ebuild15
3 files changed, 91 insertions, 7 deletions
diff --git a/media-video/miro/ChangeLog b/media-video/miro/ChangeLog
index 358c3129a3c0..4d2eb4dd4a7c 100644
--- a/media-video/miro/ChangeLog
+++ b/media-video/miro/ChangeLog
@@ -1,11 +1,18 @@
# ChangeLog for media-video/miro
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/miro/ChangeLog,v 1.3 2009/11/20 14:47:44 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/miro/ChangeLog,v 1.4 2009/11/28 15:09:34 volkmar Exp $
+
+ 28 Nov 2009; Mounir Lamouri <volkmar@gentoo.org> miro-2.5.3.ebuild,
+ +files/miro-2.5.3-remove-pkg-config-list-all.patch:
+ Remove 'pkg-config --list-all' call, bug 294183
20 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org> miro-2.5.3.ebuild:
keyword with ~amd64. Per bug #291673.
30 Oct 2009; Mounir Lamouri <volkmar@gentoo.org> miro-2.5.3.ebuild:
+ Add references to upstream bugs.
+
+ 30 Oct 2009; Mounir Lamouri <volkmar@gentoo.org> miro-2.5.3.ebuild:
Add ~x86 keyword (maintainer keywording).
*miro-2.5.3 (30 Oct 2009)
diff --git a/media-video/miro/files/miro-2.5.3-remove-pkg-config-list-all.patch b/media-video/miro/files/miro-2.5.3-remove-pkg-config-list-all.patch
new file mode 100644
index 000000000000..569c68af663e
--- /dev/null
+++ b/media-video/miro/files/miro-2.5.3-remove-pkg-config-list-all.patch
@@ -0,0 +1,74 @@
+From b5acbb41f5c6b2c4ce3b4a6944459ea425d7f971 Mon Sep 17 00:00:00 2001
+From: Mounir Lamouri (volkmar) <mounir.lamouri@gmail.com>
+Date: Sat, 28 Nov 2009 14:39:19 +0100
+Subject: [PATCH] Remove use of 'pkg-config --list-all' to 'pkg-config --exists'.
+ Fix bug 4613.
+
+---
+ platform/gtk-x11/setup.py | 23 +++++++++++++----------
+ 1 files changed, 13 insertions(+), 10 deletions(-)
+
+diff --git a/platform/gtk-x11/setup.py b/platform/gtk-x11/setup.py
+index a731ff6..94dc72a 100755
+--- a/platform/gtk-x11/setup.py
++++ b/platform/gtk-x11/setup.py
+@@ -297,6 +297,14 @@ def parse_pkg_config(command, components, options_dict = None):
+
+ return options_dict
+
++def package_exist(package_name):
++ """
++ Return True if the package is present in the system. False otherwise.
++ The check is made with pkg-config.
++ """
++ # pkg-config returs 0 if the package is present
++ return subprocess.call(['pkg-config', '--exists', package_name]) == 0
++
+ def compile_xine_extractor():
+ rv = os.system("gcc %s -o %s `pkg-config --libs --cflags gdk-pixbuf-2.0 glib-2.0 libxine`" %
+ (os.path.join(platform_dir, "xine/xine_extractor.c"), os.path.join(platform_dir, "xine/xine_extractor")))
+@@ -346,11 +354,6 @@ fi
+
+ #### MozillaBrowser Extension ####
+ def get_mozilla_stuff():
+- try:
+- packages = get_command_output("pkg-config --list-all")
+- except RuntimeError, error:
+- sys.exit("Package config error:\n%s" % (error,))
+-
+ if XPCOM_LIB and GTKMOZEMBED_LIB and XULRUNNER_19 != None:
+ print "\nUsing XPCOM_LIB, GTKMOZEMBED_LIB and XULRUNNER_19 values...."
+ xulrunner19 = XULRUNNER_19
+@@ -360,24 +363,24 @@ def get_mozilla_stuff():
+ else:
+ print "\nTrying to figure out xpcom_lib, gtkmozembed_lib, and xulrunner_19 values...."
+ xulrunner19 = False
+- if re.search("^libxul", packages, re.MULTILINE):
++ if package_exist('libxul'):
+ xulrunner19 = True
+ xpcom_lib = 'libxul'
+ gtkmozembed_lib = 'libxul'
+
+- elif re.search("^xulrunner-xpcom", packages, re.MULTILINE):
++ elif package_exist('xulrunner-xpcom'):
+ xpcom_lib = 'xulrunner-xpcom'
+ gtkmozembed_lib = 'xulrunner-gtkmozembed'
+
+- elif re.search("^seamonkey-xpcom", packages, re.MULTILINE):
++ elif package_exist('seamonkey-xpcom'):
+ xpcom_lib = 'seamonkey-xpcom'
+ gtkmozembed_lib = 'seamonkey-gtkmozembed'
+
+- elif re.search("^mozilla-xpcom", packages, re.MULTILINE):
++ elif package_exist('mozilla-xpcom'):
+ xpcom_lib = 'mozilla-xpcom'
+ gtkmozembed_lib = 'mozilla-gtkmozembed'
+
+- elif re.search("^firefox-xpcom", packages, re.MULTILINE):
++ elif package_exist('firefox-xpcom'):
+ xpcom_lib = 'firefox-xpcom'
+ gtkmozembed_lib = 'firefox-gtkmozembed'
+
+--
+1.6.3.3
+
diff --git a/media-video/miro/miro-2.5.3.ebuild b/media-video/miro/miro-2.5.3.ebuild
index 67ca57bdc95a..0094f54cce44 100644
--- a/media-video/miro/miro-2.5.3.ebuild
+++ b/media-video/miro/miro-2.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/miro/miro-2.5.3.ebuild,v 1.3 2009/11/20 14:47:44 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/miro/miro-2.5.3.ebuild,v 1.4 2009/11/28 15:09:34 volkmar Exp $
EAPI="2"
@@ -45,20 +45,22 @@ S="${WORKDIR}/${P}/platform/gtk-x11"
# psyco can make miro speedier, add a USE flag, recommand in postinst ?
# TODO:
-# create a real test suite
-# try to have a real xine/gstreamer choice
+# create a real test suite, upstream bug 12369
+# try to have a real xine/gstreamer choice, upstream bug 12371
src_prepare() {
# install only needed locales
- epatch "${FILESDIR}"/${P}-fix-locale.patch
+ epatch "${FILESDIR}"/${P}-fix-locale.patch # upstream bug 12368
# fix debug mode
epatch "${FILESDIR}"/${P}-fix-debug.patch
# disable xine hack which is failing
epatch "${FILESDIR}"/${P}-disable-xine-hack.patch
# prevent installing unneeded test files
- epatch "${FILESDIR}"/${P}-dont-install-test-files.patch
+ epatch "${FILESDIR}"/${P}-dont-install-test-files.patch # upstream bug 12370
# do not show --unittest option
- epatch "${FILESDIR}"/${P}-remove-unittest-option.patch
+ epatch "${FILESDIR}"/${P}-remove-unittest-option.patch # upstream bug 12370
+ # remove 'pkg-config --list-all' call, bug 294183, upstream bug 4613
+ epatch "${FILESDIR}"/${P}-remove-pkg-config-list-all.patch
# disable autoupdate
sed -i -e "/autoupdate/d" ../../portable/startup.py || die "sed failed"
@@ -80,6 +82,7 @@ src_prepare() {
src_test() {
# there is a test suite but it has been designed to be used when installed
# should be fixed
+ #./run.sh --unittests || die "tests failed"
:
}