summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/arping/arping-1.06-r1.ebuild')
-rw-r--r--net-analyzer/arping/arping-1.06-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/arping/arping-1.06-r1.ebuild b/net-analyzer/arping/arping-1.06-r1.ebuild
new file mode 100644
index 000000000000..d1b51e920f56
--- /dev/null
+++ b/net-analyzer/arping/arping-1.06-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/arping/arping-1.06-r1.ebuild,v 1.1 2003/08/21 04:36:29 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=ARPing"
+SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.0.2a-r3
+ <net-libs/libnet-1.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-libnet-1.0.patch
+ sed -i "s/CFLAGS=-g/CFLAGS=-g ${CFLAGS}/" Makefile
+}
+
+src_compile() {
+ make linux || die
+}
+
+src_install() {
+ newsbin arping arping1
+ newman arping.8 arping1.8
+ dodoc LICENSE README
+}