summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/iptraf/files/iptraf-3.0.0-Makefile.patch')
-rw-r--r--net-analyzer/iptraf/files/iptraf-3.0.0-Makefile.patch23
1 files changed, 21 insertions, 2 deletions
diff --git a/net-analyzer/iptraf/files/iptraf-3.0.0-Makefile.patch b/net-analyzer/iptraf/files/iptraf-3.0.0-Makefile.patch
index 9a5274d89835..29f514b0d1cd 100644
--- a/net-analyzer/iptraf/files/iptraf-3.0.0-Makefile.patch
+++ b/net-analyzer/iptraf/files/iptraf-3.0.0-Makefile.patch
@@ -1,5 +1,6 @@
---- ./iptraf-3.0.0.orig/src/Makefile 2006-01-10 07:51:13.000000000 +0100
-+++ ./iptraf-3.0.0/src/Makefile 2006-01-10 07:53:33.000000000 +0100
+diff -Naur iptraf-3.0.0~orig/src/Makefile iptraf-3.0.0/src/Makefile
+--- iptraf-3.0.0~orig/src/Makefile 2009-03-20 21:50:35.000000000 +0100
++++ iptraf-3.0.0/src/Makefile 2009-03-20 21:52:35.000000000 +0100
@@ -29,10 +29,11 @@
# options to be passed to the compiler. I don't believe they need to be
# modified (except for -m486 on non-Intel x86 platforms).
@@ -16,3 +17,21 @@
# you may want to change this to point to your ncurses include directory
# if the ncurses include files are not in the default location.
+@@ -111,7 +112,7 @@
+ $(CC) $(LDOPTS) $(PROF) -o iptraf $(OBJS) $(LIBS)
+
+ textlib:
+- make -C ../support
++ $(MAKE) -C ../support
+
+ %.o: %.c *.h version
+ $(CC) $(CFLAGS) $(DIRS) $(INCLUDEDIR) $(VERSION) $(PLATFORM) $(PROF) $(DEBUG) $(EXECPERM) $(BSSETTING) -c -o $*.o $<
+@@ -130,7 +131,7 @@
+
+ clean:
+ rm -f *.o *~ core $(BINS)
+- make -C ../support clean
++ $(MAKE) -C ../support clean
+
+ # I just included this rule to clear out the .o files, leaving the
+ # executables, stripped and ready for packing.