summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/nmap-5.21.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-5.21.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-analyzer/nmap/nmap-5.21.ebuild b/net-analyzer/nmap/nmap-5.21.ebuild
index d3d252139f1e..b2cfbdf33a03 100644
--- a/net-analyzer/nmap/nmap-5.21.ebuild
+++ b/net-analyzer/nmap/nmap-5.21.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-5.21.ebuild,v 1.5 2010/03/21 14:41:50 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-5.21.ebuild,v 1.6 2010/04/03 15:58:59 spock Exp $
EAPI="2"
+PYTHON_DEPEND="2"
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic python
MY_P=${P/_beta/BETA}
@@ -29,6 +30,10 @@ DEPEND="dev-libs/libpcre
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
epatch "${FILESDIR}/${PN}-4.75-include.patch"
epatch "${FILESDIR}/${PN}-4.75-nolua.patch"