summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/p0f/p0f-2.0.6.ebuild')
-rw-r--r--net-analyzer/p0f/p0f-2.0.6.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/p0f/p0f-2.0.6.ebuild b/net-analyzer/p0f/p0f-2.0.6.ebuild
new file mode 100644
index 000000000000..f8b8d78fcb88
--- /dev/null
+++ b/net-analyzer/p0f/p0f-2.0.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.6.ebuild,v 1.1 2006/07/09 22:11:11 vanquirius Exp $
+
+inherit eutils
+
+DESCRIPTION="p0f performs passive OS detection based on SYN packets."
+HOMEPAGE="http://lcamtuf.coredump.cx/p0f.shtml"
+SRC_URI="http://lcamtuf.coredump.cx/p0f/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="static"
+
+DEPEND="net-libs/libpcap"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+ sed -i 's;#include <net/bpf.h>;;' p0f.c || die "sed p0f.c failed"
+ sed -i -e 's|^\(all: $(FILE)\).*$|\1|' \
+ -e "s|^\(CFLAGS.*=\).*$|\1${CFLAGS}|" mk/* || die "sed makefiles failed"
+}
+
+src_compile() {
+ local static
+ use static && static="static"
+ emake ${static} || die "emake ${static} failed"
+ emake ${static} p0fq || die "emake ${static} p0fq failed"
+}
+
+src_install () {
+ use static && mv p0f-static p0f
+ dosbin p0f p0frep test/p0fq || die
+
+ insinto /etc/p0f
+ doins p0f.fp p0fa.fp p0fr.fp
+
+ doman p0f.1 || die
+ cd doc
+ dodoc ChangeLog CREDITS KNOWN_BUGS README TODO
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die "newconfd failed"
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN} || die "newinitd failed"
+}
+
+pkg_postinst(){
+ einfo "Adjust /etc/conf.d/p0f to your liking before using the"
+ einfo "init script. For more information on options, read man p0f."
+}