summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ostinato/ChangeLog10
-rw-r--r--net-analyzer/ostinato/metadata.xml12
-rw-r--r--net-analyzer/ostinato/ostinato-0.2.ebuild26
3 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/ostinato/ChangeLog b/net-analyzer/ostinato/ChangeLog
new file mode 100644
index 000000000000..79ef84524da3
--- /dev/null
+++ b/net-analyzer/ostinato/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/ostinato
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ostinato/ChangeLog,v 1.1 2010/10/23 02:02:19 c1pher Exp $
+
+*ostinato-0.2 (23 Oct 2010)
+
+ 23 Oct 2010; Dane Smith <c1pher@gentoo.org> +ostinato-0.2.ebuild,
+ +metadata.xml:
+ New ebuild for Ostinato. Moved from Sunrise overlay wrt bug 317201.
+
diff --git a/net-analyzer/ostinato/metadata.xml b/net-analyzer/ostinato/metadata.xml
new file mode 100644
index 000000000000..da8755dc5145
--- /dev/null
+++ b/net-analyzer/ostinato/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd></herd>
+ <maintainer>
+ <email>c1pher@gentoo.org</email>
+ <name>Dane Smith</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
+
diff --git a/net-analyzer/ostinato/ostinato-0.2.ebuild b/net-analyzer/ostinato/ostinato-0.2.ebuild
new file mode 100644
index 000000000000..518dee3b447e
--- /dev/null
+++ b/net-analyzer/ostinato/ostinato-0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ostinato/ostinato-0.2.ebuild,v 1.1 2010/10/23 02:02:19 c1pher Exp $
+
+EAPI=2
+inherit qt4-r2
+
+DESCRIPTION="A packet generator and analyzer"
+HOMEPAGE="http://code.google.com/p/ostinato/"
+SRC_URI="http://ostinato.googlecode.com/files/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/protobuf
+ net-libs/libpcap
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-script:4"
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ eqmake4 PREFIX=/usr ost.pro
+}