summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/driftnet/ChangeLog7
-rw-r--r--net-analyzer/driftnet/driftnet-0.1.6.ebuild46
-rw-r--r--net-analyzer/driftnet/files/digest-driftnet-0.1.61
-rw-r--r--net-analyzer/driftnet/files/driftnet-0.1.6-nogtk.patch21
4 files changed, 75 insertions, 0 deletions
diff --git a/net-analyzer/driftnet/ChangeLog b/net-analyzer/driftnet/ChangeLog
new file mode 100644
index 000000000000..796b85d1df5e
--- /dev/null
+++ b/net-analyzer/driftnet/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-analyzer/driftnet
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/driftnet/ChangeLog,v 1.1 2002/07/19 04:23:43 spider Exp $
+
+*driftnet-0.16 (19 Jul 2002)
+ 19 Jul 2002; Spider <spider@gentoo.org> driftnet-0.16.ebuild :
+ New package
diff --git a/net-analyzer/driftnet/driftnet-0.1.6.ebuild b/net-analyzer/driftnet/driftnet-0.1.6.ebuild
new file mode 100644
index 000000000000..2506c662ba07
--- /dev/null
+++ b/net-analyzer/driftnet/driftnet-0.1.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/driftnet/driftnet-0.1.6.ebuild,v 1.1 2002/07/19 04:23:43 spider Exp $
+
+DESCRIPTION="Driftnet is a program which listens to network traffic and picks out images from TCP streams it observes."
+HOMEPAGE="http://www.ex-parrot.com/~chris/driftnet/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+
+DEPEND="media-libs/jpeg
+ media-libs/libungif
+ net-libs/libpcap
+ gtk? ( <x11-libs/gtk+-1.3.0 )"
+
+
+RDEPEND="media-sound/mpg123"
+SRC_URI="http://www.ex-parrot.com/~chris/${PN}/${P}.tar.gz"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ if [ `use gtk` ]
+ then
+ emake || die "gtk+ build failed"
+ mv driftnet driftnet-gtk
+ make clean
+ fi
+ patch -p1 <${FILESDIR}/${P}-nogtk.patch
+ emake || die
+}
+
+src_install () {
+ dobin driftnet
+ doman driftnet.1
+ use gtk && dobin driftnet-gtk
+ dodoc CHANGES COPYING CREDITS README TODO
+
+ einfo "marking the no-display driftnet as setuid root."
+ chown root.wheel ${D}/usr/bin/driftnet
+ chmod 750 ${D}/usr/bin/driftnet
+ chmod u+s ${D}/usr/bin/driftnet
+
+}
+
diff --git a/net-analyzer/driftnet/files/digest-driftnet-0.1.6 b/net-analyzer/driftnet/files/digest-driftnet-0.1.6
new file mode 100644
index 000000000000..1b17b23826ab
--- /dev/null
+++ b/net-analyzer/driftnet/files/digest-driftnet-0.1.6
@@ -0,0 +1 @@
+MD5 8e11d77770452f97bb3c23f510489815 driftnet-0.1.6.tar.gz 36989
diff --git a/net-analyzer/driftnet/files/driftnet-0.1.6-nogtk.patch b/net-analyzer/driftnet/files/driftnet-0.1.6-nogtk.patch
new file mode 100644
index 000000000000..150122edf7a9
--- /dev/null
+++ b/net-analyzer/driftnet/files/driftnet-0.1.6-nogtk.patch
@@ -0,0 +1,21 @@
+diff -ur driftnet-0.1.5/Makefile driftnet-0.1.5-new/Makefile
+--- driftnet-0.1.5/Makefile Wed Jun 26 17:13:15 2002
++++ driftnet-0.1.5-new/Makefile Mon Jul 8 22:52:07 2002
+@@ -32,14 +32,14 @@
+
+ # Optional C compiler and linker flags. Typical driftnet builds have support
+ # for displaying captured images in an X window, and need the following flags:
+-CFLAGS += `gtk-config --cflags`
+-LDLIBS += -ljpeg -lungif `gtk-config --libs`
++# CFLAGS += `gtk-config --cflags`
++# LDLIBS += -ljpeg -lungif `gtk-config --libs`
+
+ # Alternatively, you can build a version of driftnet which can only be used
+ # in `adjunct' mode as the back end for some other image-processing program. To
+ # use this, comment out the two preceding CFLAGS and LDLIBS lines and uncomment
+ # the following line:
+-#CFLAGS += -DNO_DISPLAY_WINDOW
++CFLAGS += -DNO_DISPLAY_WINDOW
+
+ # On systems with a C99 compiler, driftnet will use <stdint.h> for the
+ # definitions of types such as uint8_t. On other systems like Solaris, these